Listener.log is growing fast.
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 5 of 5

Thread: Listener.log is growing fast.

Hybrid View

  1. #1
    Join Date
    Jun 2006
    Posts
    40

    Listener.log is growing fast.

    As the listener.log on one of my database is growing fast,(like in one day it increases upto 20 MB) everyday i've to delete the log and restart the listener.
    Then i tried to make the listener.log off.
    For that I tried following steps:

    I've set logging_listener=off in listener.ora
    also tried to make log_status=off
    But still it's growing.
    Can u pls provide proper solution to off the listener.log ? After making log level off, whether it cause any effect to database?

    Thanks in advance.

  2. #2
    Join Date
    Apr 2001
    Location
    Bangalore, India
    Posts
    727
    LSNRCTL> show log_status
    Connecting to (ADDRESS=(PROTOCOL=tcp)(HOST=)(PORT=1521))
    LISTENER parameter "log_status" set to ON
    The command completed successfully

    See the log status
    Thomas Saviour(royxavier@yahoo.com)
    Technical Lead (Databases)
    Thomson Reuters (Markets)

    http://ora600tom.wordpress.com/

  3. #3
    Join Date
    Mar 2002
    Location
    Mesa, Arizona
    Posts
    1,204
    1. To permanently turn off listener logging, modify the listener.ora and add/change LOGGING_*YOUR_LISTENER_NAME*=OFF

    2. To temporarily turn off listener logging, from lsnrctl prompt:
    LSNRCTL>SET LOGGING_*YOUR_LISTENER_NAME*=OFF

    3. To get the current listener logging status, from lsnrctl prompt:
    LSNRCTL>show log_status

    Ken
    Last edited by KenEwald; 07-24-2006 at 11:33 AM. Reason: removing tags...
    "I do not fear computers. I fear the lack of them." Isaac Asimov
    Oracle Scirpts DBA's need

  4. #4
    Join Date
    Jun 2006
    Posts
    40
    Hi,
    Today i've stopped the listener,deleted the previous logs and add parameter logging_listener=off to listener.ora ,so the logging get stopped.
    But before that when i gave
    LSNRCTL> set logging_listener=off
    It says undefined set command.
    Why is it so?
    Let me know your opinion.

  5. #5
    Join Date
    Apr 2001
    Location
    Bangalore, India
    Posts
    727
    Becuase it is wrong..
    Thomas Saviour(royxavier@yahoo.com)
    Technical Lead (Databases)
    Thomson Reuters (Markets)

    http://ora600tom.wordpress.com/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width