low open file
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 7 of 7

Thread: low open file

  1. #1
    Join Date
    Apr 2001
    Location
    Bangalore, India
    Posts
    727

    low open file

    Hi
    I got a 3 node cluster implemented with OS Linux and 10g RAC
    Code:
    uname -a
    Linux XXXX 2.6.9-34.ELsmp #1 SMP Fri Feb 24 16:56:28 EST 2006 x86_64 x86_64 x86_64 GNU/Linux
    [root@xxxx etc]# sysctl -a | grep fs.file-max
    fs.file-max = 1599224
    I know fs.file-max is not set to oracle recoomended value (fs.file-max = 65536) rather it is still the default value.

    Now, when I start oracle i get the message in alert log as

    WARNING:Oracle instance running on a system with low open file descriptor limit. Tune your system to increase this limit to avoid
    severe performance degradation.

    Code:
    [oracle@xxxx ~]$ ulimit -a
    core file size          (blocks, -c) 0
    data seg size           (kbytes, -d) unlimited
    file size               (blocks, -f) unlimited
    pending signals                 (-i) 1024
    max locked memory       (kbytes, -l) 50000000
    max memory size         (kbytes, -m) unlimited
     open files                      (-n) 131072 
    pipe size            (512 bytes, -p) 8
    POSIX message queues     (bytes, -q) 819200
    stack size              (kbytes, -s) 10240
    cpu time               (seconds, -t) unlimited
    max user processes              (-u) 131072
    virtual memory          (kbytes, -v) unlimited
    file locks                      (-x) unlimited
    So, can anybody tell me from where the warning originates? And what is the solution?
    Last edited by Thomasps; 07-11-2006 at 06:32 AM.
    Thomas Saviour(royxavier@yahoo.com)
    Technical Lead (Databases)
    Thomson Reuters (Markets)

    http://ora600tom.wordpress.com/

  2. #2
    Join Date
    Sep 2002
    Location
    England
    Posts
    7,331
    what is the db_files set to - you can lower that if it set too high for what you have and the message shuld go away

  3. #3
    Join Date
    Apr 2001
    Location
    Bangalore, India
    Posts
    727
    as per the metalink fs.file-max > (db_files * 2) + control files + log files + over head. In my case it is 2000 data files and total comes to max: 4500 and only one database in the cluster. See my OS limits are far far above that.
    Thomas Saviour(royxavier@yahoo.com)
    Technical Lead (Databases)
    Thomson Reuters (Markets)

    http://ora600tom.wordpress.com/

  4. #4
    Join Date
    Sep 2002
    Location
    England
    Posts
    7,331
    well ive had the same, reduce db_files to the correct value for what i actually have and the error went away

  5. #5
    Join Date
    Apr 2001
    Location
    Bangalore, India
    Posts
    727
    Well, I changed the db_files from 2000 to 500.. still same message

    Code:
    Tue Jul 11 15:04:58 2006
    cluster interconnect IPC version:Oracle UDP/IP (generic)
    IPC Vendor 1 proto 2
    Tue Jul 11 15:04:58 2006
    WARNING:Oracle instance running on a system with low open file descriptor
            limit. Tune your system to increase this limit to avoid
            severe performance degradation.
    I am missing something some where
    Thomas Saviour(royxavier@yahoo.com)
    Technical Lead (Databases)
    Thomson Reuters (Markets)

    http://ora600tom.wordpress.com/

  6. #6
    Join Date
    Jun 2006
    Posts
    259
    Are you using CRS to start the cluster?

    There is an oracle bug that is fixed in 10.2.0.3

    workaround:

    edit init.crsd
    ulimit -n unlimited

    Then restart crs to get the new settings.

  7. #7
    Join Date
    Apr 2001
    Location
    Bangalore, India
    Posts
    727
    Thanks.
    yes, I am using CRS to start the cluster.
    Are you refering to the bug: 4462367?. Many Thanks.
    Thomas Saviour(royxavier@yahoo.com)
    Technical Lead (Databases)
    Thomson Reuters (Markets)

    http://ora600tom.wordpress.com/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width