DB_Link
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 3 of 3

Thread: DB_Link

  1. #1
    Join Date
    Apr 2003
    Posts
    18

    DB_Link

    Have any one experience the following problem with a db_link?
    My OS is HP-UX 11.0, database is Oracle 9.2.0.7

    Problem:
    I have establish a db_link to push information to a remote server
    via two Procedures. Every thursday night, I shutdown my database to do a coldbackup. When the database restarts, the db_link become inactive. When I check on friday morning it showed this message:

    link PM_online error: Ora-12154: TNS:could not resolve service name.

    I checked to insure all oracle processes were up, and they were.
    I tried testing the link by selecting * from dual@PM_line. Got the oracle error ora-12154.

    How can I re-establish my link without bouncing the database?

  2. #2
    Join Date
    Sep 2002
    Location
    England
    Posts
    7,333
    dont bounce it in the first place seems to be the best solution

    TNS-12154 means the service name you are using in the db link cant be found in the tnsnames.ora file

  3. #3
    Join Date
    Apr 2003
    Posts
    18
    I checked my tnsnames.ora file, the service name that I am using for the db_link is there and it is in the correct format.
    Why is it not being detected after I restarting the database from a cold backup?
    Is there a simple fix to this problem without bouncing the database?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width