grant select succeeds, but wont let users select
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 3 of 3

Thread: grant select succeeds, but wont let users select

  1. #1
    Join Date
    Aug 2005
    Posts
    69

    grant select succeeds, but wont let users select

    hi,
    have logged on as sys done grant select on v$xatrans$ to public and commit
    all succeeded.
    then logged on as another user and did select * from v$xatrans$ and message table or view does not exist ???
    do I have to do somethign else as it is a v$ view - like create a synonym for it or something then grant select on that?
    I have done everything as per the literature for allowing oracle-xa support, but this is failing and they just tell you to grant select on it which I have done

    help?

  2. #2
    Join Date
    Jul 2002
    Posts
    335
    Youu can create a synonym (read up on public and private synoyms to see the difference) or when you do the select, prefix the table/view name with the owner, i.e.

    select * from "schema_name"."table_name";

    In your case:

    select * from sys.v$xatrans$;

    Bazzza

  3. #3
    Join Date
    Sep 2005
    Location
    Delhi
    Posts
    78
    There could be many cases
    1. If it is a dictionary table or the table owned the sys then do
    alter system set o7_dictionary_accessibility=true scope=spfile
    startup force then issue select
    NO NEED TO USER OWNER WITH OBJECT NAME.

    2. if it is not any dictionary table then
    use owner while using it with any select statement.
    ~KD.DBA~

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width