Ora-12504
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 4 of 4

Thread: Ora-12504

  1. #1
    Join Date
    Dec 2005
    Posts
    2

    Ora-12504

    Hi Everyone,
    I tried to start another application which is using Oracle and I got a error message:
    "ORA-12504: TNS:listener was not given the SERVICE_NAME in CONNECT_DATA"

    I checked the Oracle error messages and I sew that the ORA-12504 is
    "ORA-12504: TNS:listener was not given the SID in CONNECT_DATA"

    After that I thought that the problem is wih the HOST part in the TNSNAMES.ORA and LISTENER.ORA because I can see SID in the TNSNAMES.ora and LISTENER.ora,
    so I modified it from HOST = szend to HOST = localhost. I was a bad idea, I know.

    It was not working and I did it back, so currently HOST = szend. But it is not working and I don't understand why.

    I checked the Oracle services and I sew that the Ora92Agent is not running. I tried to restarted, wondering that's why I'm not able to connect to the database again.
    But I cannot restart it.

    Anybody has any idea? The SERVICE_NAME and SID is the same? What is connection between them? How I can fix it?

    Thanks in advance
    Adam

  2. #2
    Join Date
    Sep 2002
    Location
    England
    Posts
    7,331
    post you listener.ora and tnsnames.ora

  3. #3
    Join Date
    Dec 2005
    Posts
    2
    tomorrow can you have a look at the thread, because the files are in my computer at home?
    thanks
    Adam

  4. #4
    Join Date
    Oct 2000
    Location
    Saskatoon, SK, Canada
    Posts
    3,925
    Please provide the DB version. Also, if your application is on a different server, make sure that you can ping the database server using "ping". Then make sure the listener is up. you can check this using "lsnrctl status" or "lsnrctl services". Make sure you can establish a server side connection using sqlplus. This would alleviate the problem being on the server side. Then on the client side, after verifying that you can contact the remote system using ping, if you have an oracle client install on the client side, try using the tnsping "service name". Also, check your service name is fully qualified name or there is not entry in the sqlnet.ora file that would append the domain information to the end.

    Hence these check would give you clue on where the problem is at.
    Thanx
    Sam



    Life is a journey, not a destination!


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width