Cannot start Oracle Agent on Linux
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 2 of 2

Thread: Cannot start Oracle Agent on Linux

  1. #1
    Join Date
    Nov 2005
    Posts
    1

    Exclamation Cannot start Oracle Agent on Linux

    Sorry, I accidentally closed my thread, positing again, Need help!!!

    I have been trying to start the Oracle Intelligent Agent on Linux to no avail. I have the listener.ora file configured properly as do I have the oratab, etc. When I issue the command:

    agentctl start, if fails and when reviewing the logs this the error I recieve:

    DBSNMP for Linux 2.4.21-27.0.2.ELsmp: release 9.2.0.4.0 - Production on 18-NOV-0
    5 10:53:31
    Discovering services on bl-ux-wapdbqa1.na.dir.bunge.com configured on host addre
    sses {bl-ux-wapdbqa1.na.dir.bunge.com 10.151.10.253 bl-ux-wpsdb1.na.dir.bunge.co
    m 10.151.11.114}
    Using oratab file /etc/oratab
    Warning : LISTENER defined in /opt/oracle/product/9.2.0/network/admin/listener.o
    ra will be skipped, because it does not monitor any of the valid SIDs {WPS50 WPS
    DBDEV JCRDBDEV WPSDBMOD JCRDBMOD WPSDBPRD JCRDBPRD}
    Warning : No Listener found for SID WPS50. WPS50 will be skipped
    Warning : No Listener found for SID WPSDBDEV. WPSDBDEV will be skipped
    Warning : No Listener found for SID JCRDBDEV. JCRDBDEV will be skipped
    Warning : No Listener found for SID WPSDBMOD. WPSDBMOD will be skipped
    Warning : No Listener found for SID JCRDBMOD. JCRDBMOD will be skipped
    Warning : No Listener found for SID WPSDBPRD. WPSDBPRD will be skipped
    Warning : No Listener found for SID JCRDBPRD. JCRDBPRD will be skipped
    using INVENTORY_LOCATION
    Could not find targets.xml file.

    Has anyone else run into this? What should I do to fix it. I have tried all the troubleshooting tips, and it still will not start? Should I re-install? Please advise

  2. #2
    Join Date
    Jul 2002
    Posts
    335
    Can you post the results of what actually happens when you do:
    $> agentctl start

    Is your environment set?

    Is the agent installed in a separate home?

    What log did you post out of interest? I only query it, because it mentions a targets.xml file, the 9i agent uses tcl, and the snmp_rw.ora, snmp_ro.ora and services.ora show what targets the agent monitors.

    Have you tried cleanstarting the agent as well?

    Bazza

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width