DBAsupport.com Forums - Powered by vBulletin
Results 1 to 3 of 3
  1. #1
    Join Date
    Dec 2000


    Some time ago I posted a message about Invalid objects in the SYS schema. I found a reason - other people performed 8.1.5 -> 8.1.6 upgraid, and something was did wrong...

    Using catproc, catrep and utlrp I fixed almost everithing -
    but now I have a lot of invalid Java classes, near of 20%, as I see, and I just have no clue how could I recompile it.
    I got that new Toad 6.5 which could show them, and I see now this classes - they are mostly in /oracle/jpub/reflect/ ,
    /oracle/jdbc/, /oracle/net/, etc. directories.
    I tried to recompile them (as SYSTEM, as SYS) but got the message: The following error has occurred: ORA-01031: insufficient privileges.

    That Java stuff is pretty new for me - I tried to find an answer in documentation, but found nothing.
    How should i deal with that problem? Which section of Oracle8i documentation covers that specific set of Java stuff administration problems?

  2. #2
    Join Date
    Dec 2000
    I don`t know that is going on with that damn classes - but something don`t want to be compiled, something is compiling OK, and then all classes in that section becomes OK,
    well, that`s the mess!!!
    Do we have any FAQ or guaides about this administration tasks, I mean Java objects administration?

  3. #3
    Join Date
    Dec 2000
    Well, it`s a pretty stupid algorithm, but:
    I found only one utility which could recompile java classes -
    Login as SYS, try to recompile first class. some could not be recompiled, but some - can.
    Recompile first, if it was successful, recompile next, after
    first "priveleges" error do refresh comand. With very high probability you will see that all section of classes now is VALID.

    Can it be done in more simple way?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Click Here to Expand Forum to Full Width

We have made updates to our Privacy Policy to reflect the implementation of the General Data Protection Regulation.