cannot execute binary file
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 8 of 8

Thread: cannot execute binary file

Hybrid View

  1. #1
    Join Date
    Aug 2005
    Location
    Nigeria
    Posts
    14

    cannot execute binary file

    hi all,

    Am trying to install oracle10g release 1 on Linux 3 server in my company but when running ./runInstaller. I kept having cannot execute binary file problem. can anybody tell me what is wrong? Any help will be higly appreciated.
    Last edited by wole; 10-04-2005 at 11:32 AM.
    The purpose of life is a life of purpose.

  2. #2
    Join Date
    Sep 2002
    Location
    England
    Posts
    7,331
    do you have the right version of oracle for your platform?

    (presuming the file has execute permission on it)

  3. #3
    Join Date
    Jan 2001
    Posts
    642
    Which user are you logged in?
    Check the file permissions for runInstaller.
    ( eg:
    -rwxr-xr-x 1 oracle dba 1330 Aug 17 11:26 runInstaller
    drwxrwxr-x 9 oracle dba 2560 Aug 17 11:26 stage
    )
    run it as . ./runInstaller (check your path variable)
    There is always a better way to do the things.

  4. #4
    Join Date
    Aug 2005
    Location
    Nigeria
    Posts
    14
    Thanks Guys,

    I guess am not running the right version of oracle for my platform,my system is hp itanium,when i ran uname -a, i got this report: Linux.Localdomain 2.4.21-15.Elsmp #1 SMP Thu Apr 22 00:18:24 EDT i686 i686 i386 GNU/Linux
    but the version i have is Enterprise/Standard Edition for Linux Itanium.
    Can you suggest the version i can use for the installation.

    once again thanks in advance.
    The purpose of life is a life of purpose.

  5. #5
    Join Date
    Sep 2002
    Location
    England
    Posts
    7,331
    Looks like you just have a normal 32 bit x86 os, download oracle for Linux x86

  6. #6
    Join Date
    Aug 2005
    Location
    Nigeria
    Posts
    14
    thanks Davey,
    have succeeded in downloading the oracle for Linux x86 and av been able to start the OUI. but the problems am encountering now is am unable to go beyond the product-specific prerequisite checks as follows:
    1. Checking operating system package requirements ....
    Checking for gcc-3.2; found not found. Failed <<<<
    Checking for libaio-0.3.96; found not found failed<<<<
    2. Checking recommended glibc version error
    checking recommended glibc version
    expected result: ATLEAST=2.3.2-95.27
    actual result: 2.3.2-95.20
    check complete. The overall result of this check is: failed <<<<

    Can u pls tell me what next?
    Thanks once again.
    The purpose of life is a life of purpose.

  7. #7
    Join Date
    Sep 2002
    Location
    England
    Posts
    7,331
    you dont have gcc-3.2 or libaio-0.3.96 and glibc version is wrong

    upgrade them or install them if not present

  8. #8
    Join Date
    Aug 2005
    Location
    Nigeria
    Posts
    14
    Thanks Davey, U r too much. it ran sucessfully.
    The purpose of life is a life of purpose.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width