Help sought for emctl
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 6 of 6

Thread: Help sought for emctl

  1. #1
    Join Date
    Oct 2004
    Location
    Warminster,PA
    Posts
    10

    Help sought for emctl

    Thanks to unemployment, I can resume working on my certification. I am having to shake rust off from last time and I am having difficulty starting up Oracle Enterprise Manager (on 10g).

    Notes:
    I issued >emctl start dbconsole and I got:
    N:\oracle\product\101~1.0\Db_1>emctl start dbconsole
    Oracle Enterprise Manager 10g Database Control Release 10.1.0.2.0
    Copyright (c) 1996, 2004 Oracle Corporation. All rights reserved.
    http://192.168.2.25:5501/em/console/aboutApplication
    Starting Oracle Enterprise Manager 10g Database Control ...The service name is invalid.

    More help is available by typing NET HELPMSG 2185.
    ==
    I have set ORACLE_HOME=path and ORACLE_SID=orcl
    ==
    I try: >emctl config console
    N:\oracle\product\101~1.0\Db_1>emctl config console 192.168.2.25_orcl
    Oracle Enterprise Manager 10g Database Control Release 10.1.0.2.0
    Copyright (c) 1996, 2004 Oracle Corporation. All rights reserved.
    192.168.2.25_orcl (Access is denied)
    ===
    Here is contents of emdctl.trc (emdctl.log is empty)
    2005-09-23 11:55:51 Thread-4980 WARN http: snmehl_connect: connect failed to (192.168.2.25:1830): No connection could be made because the target machine actively refused it.
    (error = 10061)
    ...... 12 similar lines skipped.....
    2005-09-23 13:15:53 Thread-4488 WARN http: snmehl_connect: connect failed to (192.168.2.25:1830): No connection could be made because the target machine actively refused it.
    (error = 10061)
    2005-09-23 13:55:46 Thread-5104 WARN http: snmehl_connect: connect failed to (192.168.2.25:1830): No connection could be made because the target machine actively refused it.
    (error = 10061)
    ===
    Here is contents of emoms.properties:
    #Fri Sep 23 11:03:58 EDT 2005
    #Fri Sep 23 11:03:58 EDT 2005
    oracle.sysman.emSDK.svlt.ConsoleServerName=192.168.2.25_Management_Service
    oracle.sysman.eml.mntr.emdRepPwd=horses5
    emdrep.ping.pingCommand=/usr/sbin/ping
    oracle.sysman.eml.mntr.emdRepPort=1521
    #2484
    oracle.sysman.eml.mntr.emdRepDBName=orcl
    oracle.sysman.emSDK.svlt.ConsoleMode=standalone
    oracle.sysman.emRep.dbConn.statementCacheSize=30
    oracle.sysman.db.isqlplusUrl=http\://192.168.2.25\:5560/isqlplus/dynamic
    oracle.sysman.emSDK.svlt.ConsoleServerPort=5500
    oracle.sysman.eml.mntr.emdRepRAC=FALSE
    oracle.sysman.emSDK.emd.rt.useMonitoringCred=true
    oracle.sysman.eml.mntr.emdRepPwdEncrypted=FALSE
    oracle.sysman.db.isqlplusWebDBAUrl=http\://192.168.2.25\:5560/isqlplus/dba/dynamic
    oracle.sysman.emSDK.svlt.ConsoleServerHost=192.168.2.25
    oracle.sysman.emSDK.svlt.ConsoleServerHTTPSPort=5500
    oracle.sysman.eml.mntr.emdRepServer=192.168.2.25
    oracle.sysman.eml.mntr.emdRepSID=ORCL
    oracle.sysman.eml.mntr.emdRepConnectDescriptor=(DESCRIPTION\=(ADDRESS_LIST\=(ADDRESS\=(PROTOCOL\=TCP )(HOST\=basement)(PORT\=1521)))(CONNECT_DATA\=(SERVICE_NAME\=orcl)))
    oracle.sysman.emSDK.sec.ReuseLogonPassword=true
    oracle.sysman.eml.mntr.emdRepUser=SYSMAN
    oracle.sysman.db.adm.conn.statementCacheSize=2
    oracle.sysman.db.perf.conn.statementCacheSize=30

    ===
    I have NOT installed SP2 into my XP machine yet.
    ===
    I tried "opening" ports 5500 and 1830, still no diff.
    ===

    Please give me some more clues to try so I can start practicing with the OEM, thank you
    Rich Sias

  2. #2
    Join Date
    May 2002
    Posts
    2,645
    You should be able to start dbconsole via Services control panel.

    After that, your connection string will more than likely be:
    http://localhost:5500/em/console

    From there, you get the login page for Oracle Enterprise Manager 10g Database Control.

  3. #3
    Join Date
    Feb 2006
    Posts
    4
    I have a similar problem except i have insured that dbconsole service is running but my browser continues to give me a "web site is unavailable" error. the address for the console works fine after i create a DB and untill the server restarts and then after a restart i can no longer access the login page. is it possible that the address has changed? what config files do i need to modify and what would i be looking for?

    Bryan

  4. #4
    Join Date
    Mar 2004
    Location
    IA USA
    Posts
    257
    Quote Originally Posted by Sartan20
    the address for the console works fine after i create a DB and untill the server restarts and then after a restart i can no longer access the login page. is it possible that the address has changed? what config files do i need to modify and what would i be looking for?

    Bryan
    I faced the similar problem too. I just stop the dbconsole and restarted it again. Then everything is fine. The address should not change.
    You can find the port list for EM Console in the
    $ORACLE_HOME/install/portlist.ini

  5. #5
    Join Date
    Mar 2004
    Location
    IA USA
    Posts
    257
    Check the note Note:335682.1 on metalink.
    It seems that your installation missed some files.

  6. #6
    Join Date
    Feb 2006
    Posts
    4
    Is it mainly a problem associated with windows? becuase it seems that people have less problems with 10g on linux. i think i will move it over to my Fedora core 4 box cuz im beginning to hate windows more and more every day

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width