"System as SysDba" password
DBAsupport.com Forums - Powered by vBulletin
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: "System as SysDba" password

  1. #1
    Join Date
    Oct 2001
    Location
    Kuwait
    Posts
    23

    "System as SysDba" password

    Hi all
    If you try
    sqlplus "system as sysdaba"
    system asks for the password.
    whatever password you type Oracle allows you to log in

    Why ?????
    Oracle DBA
    National Bank Of Kuwait

  2. #2
    Join Date
    Sep 2005
    Posts
    278
    try this,

    / as sysdba

    it will log u on the database

  3. #3
    Join Date
    Nov 2002
    Location
    New Delhi, INDIA
    Posts
    1,796
    Quote Originally Posted by gsmathew
    Hi all
    If you try
    sqlplus "system as sysdaba"
    system asks for the password.
    whatever password you type Oracle allows you to log in

    Why ?????
    When you connect as SYSDBA privilege, you are connecting as SYS schema and not the schema associated with your username. And the schema SYS will accept any password if your OS username, through which you are logged into the machine, belongs to DBA(unix) or ORA_DBA(windows) group on the machine where Oracle database is installed.

    HTH
    Last edited by adewri; 09-11-2005 at 04:18 AM.
    Amar
    "There is a difference between knowing the path and walking the path."

    Amar's Blog  Get Firefox!

  4. #4
    Join Date
    Sep 2005
    Posts
    1
    Hi

    To enable authentication of an administrative user using password file authentication you must do the following:

    Create an operating system account for the user.
    If not already created, Create the password file using the ORAPWD utility:
    ORAPWD FILE=filename PASSWORD=password ENTRIES=max_users


    Set the REMOTE_LOGIN_PASSWORDFILE initialization parameter to EXCLUSIVE.
    Connect to the database as user SYS (or as another user with the administrative privilege).
    If the user does not already exist in the database, create the user. Grant the SYSDBA or SYSOPER system privilege to the user:
    GRANT SYSDBA to scott;


    This statement adds the user to the password file, thereby enabling connection AS SYSDBA.


    Regards,
    Sasikumar

  5. #5
    Join Date
    Sep 2002
    Location
    England
    Posts
    7,333
    Quote Originally Posted by sasikumar
    Hi

    To enable authentication of an administrative user using password file authentication you must do the following:

    Create an operating system account for the user.
    If not already created, Create the password file using the ORAPWD utility:
    ORAPWD FILE=filename PASSWORD=password ENTRIES=max_users


    Set the REMOTE_LOGIN_PASSWORDFILE initialization parameter to EXCLUSIVE.
    Connect to the database as user SYS (or as another user with the administrative privilege).
    If the user does not already exist in the database, create the user. Grant the SYSDBA or SYSOPER system privilege to the user:
    GRANT SYSDBA to scott;


    This statement adds the user to the password file, thereby enabling connection AS SYSDBA.


    Regards,
    Sasikumar
    the password file has NOTHING to do with the issue here

  6. #6
    Join Date
    Sep 2005
    Posts
    278
    Do we need we need to recreate the instance for changing the password of sys on Windows OS; is it true?

    If no, how can we change?

  7. #7
    Join Date
    Jun 2000
    Location
    Madrid, Spain
    Posts
    7,447
    Obviously it's false

    Just alter user sys identified by whatever

  8. #8
    Join Date
    Sep 2005
    Posts
    278
    Yes ur right, then what about ORAPWD which we use on UNIX systems??

    Thanks to this forum, am really learning alot here than in any institutes
    Last edited by tabreaz; 09-11-2005 at 05:43 AM.

  9. #9
    Join Date
    Jun 2000
    Location
    Madrid, Spain
    Posts
    7,447
    orapwd is used just to create password files to support remote sysdba/sysoper logins, everytime you change your sysdba passwords look how the modification date in the password file changes

  10. #10
    Join Date
    Sep 2005
    Location
    Delhi
    Posts
    78
    When u connect through system, u connect as public schema.
    Now the reason behind allowing system to connect while entering wrong password is that
    1. u are using OS authentication.(u can check it from SQLNET.ora file...
    SQLNET.AUTHENTICATION_SERVICES= (NTS))
    and there is no password file created.
    Possible Solutions are:

    1. Make SQLNET.AUTHENTICATION_SERVICES= (NONE)
    or
    2. Create a password file.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width