ora 12541: no listener
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 5 of 5

Thread: ora 12541: no listener

  1. #1
    Join Date
    Jun 2000
    Posts
    315

    ora 12541: no listener

    I am trying to connect to one of the databases through toad, and I got ora-12541: no listener. I know the listener is up and running fine. I can connect to the database through sqlplus from the same machine. All other databases can be connnected from the same machine through toad. I can also connect to the this database through toad from another machine.
    What could be wrong?

    Thanks!

  2. #2
    Join Date
    Jul 2000
    Posts
    521
    Something must have changed on the machine from where you are trying to connect. As you have made sure that the db is indeed up, it is being serviced by a listener and you can connect to it from other machines, there must be something wrong with this specific machine (client).

    Did you install new Oracle version on client ?
    svk

  3. #3
    Join Date
    Jun 2000
    Posts
    315
    This is a new machine. I can connect to other databases through the same toad on this machine, and I can connect to this database through sqlplus but not toad on this machine. I just ping and tnsping the server. Ping went through but tnsping also got 'no listener' error. Telnet is also fine.

  4. #4
    Join Date
    Jul 2000
    Posts
    521
    Check o/p of tnsping. Check that the host and port information is correct. Can you post the o/p here ?
    svk

  5. #5
    Join Date
    Jun 2000
    Posts
    315
    Thank you, svk!

    It was the port number! I used default 1521 as the port number in tnsname file. But the actually one is 1524.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width