Insufficient privileges to catalog procedures
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 3 of 3

Thread: Insufficient privileges to catalog procedures

  1. #1
    Join Date
    Jun 2000
    Posts
    417
    Bear with me, it's Monday and there's no coffee.


    I'm running adadmin to compile objects in the APPS schema. I don't know which user it's connecting to do so, either APPLSYS or APPS. Most likely APPS but it shouldn't really matter.

    The majority of the object are compiled, but a few failed. Some with real errors, and some because they have "insufficient privilege to package DBMS_PIPE" (or DBMS_LOCK). Just for a sanity check I granted execute_catalog_role to both of the users and the error still occurs. If I try to execute a procedure from sqlplus (I just used dbms_pipe.purge('dummy_argument')), it executes successfully without complaining about privileges.

    Anyone know why adadmin is yelling? (adadmin is a program which comes with applications to do some maintenance, in my case it's really doing nothing more than connecting to the database and running some PL/SQL to find invalid objects and compile them)

  2. #2
    Join Date
    Nov 2000
    Location
    greenwich.ct.us
    Posts
    9,092
    Don't you have to grant execute directly on DBMS_PIPE and DBMS_LOCK in order for another procedure to use them? I remember somewhere that privs from a role do not work the same as in a procedure...
    Jeff Hunter
    marist89@yahoo.com
    http://marist89.blogspot.com/
    Get Firefox!
    "I pledge to stop eating sharks fin soup and will not do so under any circumstances."

  3. #3
    Join Date
    Jun 2000
    Posts
    417
    Yeah, it worked if I granted execute on the packages to the users explicitly, I'm just curious why they couldn't use them to begin with. Others worked fine, I re-ran the creation scripts but that didn't help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width