OracleAgent80 problem
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 2 of 2

Thread: OracleAgent80 problem

  1. #1
    Join Date
    Dec 2000
    Posts
    1
    Hi,

    I'am getting the error message during startup of Oracle services: "Could not start OracleAgent service on \\<server name>. ERROR 0009: THE STORAGE CONTROL BLOCK ADDRESS IS INVALID".
    Does anybody know how to remedy this problem? Any input is appreciated.

    I am running Oracle 8.0.4 on WinNT workstation. The above problem occured after I unsuccessfully tried to install a new product (Developer 6) in a new Oracle home.
    Thanks, Lev

  2. #2
    Join Date
    Aug 2000
    Location
    Belgium
    Posts
    342
    Metalink :

    1) from the forum

    This is only a problem if you don't have $(ORACLE_HOME)\network\admin\
    snmp_rw.ora file when you startup the agent. In this case, the agent
    automatically generates a new snmp_rw.ora file with snmp.address strings and "HOST=your_hostname" string.Here, the agent replaces 'your_hostname' string with the actual computer name. After generating this file, it tries to use this information for startup. But it could not resolve the IP address for the computer name. It will happen only on the NT machine where the computer name is not setup to map to the host IP address.

    To fix this problem, please allow the agent to make the snmp*.ora files from scratch(deleting existing ones), then edit the snmp_rw.ora and replace the hostname with the ip address. You can then attempt restarting the agent.

    If this solves it, resolving the hostname is causing the problem. Add you hostname and corresponding IP address to your hosts file. Please check with system/network admin on this

    2) a note

    Problem Description:
    ====================

    Agent does not start. Gives specific NT error:

    System error 9: storage control block address is invalid.


    Problem Explanation:
    ====================

    During the startup of the agent, an NLS error was encountered:

    ORA-12705: invalid or unknown NLS parameter value specified
    Cause: There are two possible causes: Either an attempt was made to
    issue an ALTER SESSION statement with an invalid NLS parameter
    or value; or the NLS_LANG environment variable contains an
    invalid language, territory, or character set.

    Action: Check the syntax of the ALTER SESSION command and the NLS
    parameter, correct the syntax and retry the statement or
    specify correct values in the NLS_LANG environment variable.


    Search Words:
    =============

    OEMAGENT IAGENT
    NT-9 NMS-9
    NLS ORA_NLS32 NLSRTL32

    Solution: ERROR NT-9 WHEN STARTING AGENT

    Solution Description:
    =====================

    You check the event viewer and it indicates the Agent could not
    initialize the NLS parameters.

    You run regedit and check the following hive:

    HKEY_LOCAL_MACHINE
    SOFTWARE
    ORACLE

    The NLS parameters "ORA_NLS32" and "NLSRTL32" are missing.

    You need to check under the "/orant" directory for the NLS directory, for
    example, NLSRTL32. You then add two parameters to the registry. NLSRTL32
    (this is the same name as the directory) and ORA_NLS32.

    These parameters are added by clicking Edit -> New -> String Value.
    Then type the name in the block that appears.

    Next, you must set these parameters as follows:

    HKEY_LOCAL_MACHINE
    SOFTWARE
    ORACLE
    NLSRTL32 REG_SZ C:\ORANT\NLSRTL32
    ORA_NLS32 REG_SZE C:\ORANT\NLSRTL32\DATA


    (where C: is the drive containing the ORANT installation directory)


    Starting from Oracle8, the NLS variables have the version number '33'.

    Also, it is possible that the agent is installed in a different "ORACLE_HOME",
    meaning the registry variables will need to be searched in a different
    location.

    If the agent is not installed in the default directory, check the following:

    1) Go to the "$ORACLE_HOME/bin directory.

    2) Read the "ORACLE.KEY" file. This file contains the registry hive that
    contains the variables for this "$ORACLE_HOME".

    3) Then go to that registry hive, and follow the procedure described above,
    using the number 33 instead of 32.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width