Overcome UNIX OS file limit in RMAN backup
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 8 of 8

Thread: Overcome UNIX OS file limit in RMAN backup

  1. #1
    Join Date
    Nov 2000
    Posts
    205

    Here is my code and errors. I think it is because it made a file up to the OS limit, how do I say it to make several files etc.. or how do I overcome this? I did a listing to show how big the file is as well, at the end.

    Please help.

    Thanks,
    Nirasha
    RMAN> run {
    2> allocate channel incr0dsk type disk;
    3> backup
    4> incremental level 0
    5> tag incr0_bkup
    6> format '/u07/tapebackup/tape0/fndry_p/%d_%u'
    7> (database include current controlfile);
    8> release channel incr0dsk;
    9> }

    RMAN-03022: compiling command: allocate
    RMAN-03023: executing command: allocate
    RMAN-08030: allocated channel: incr0dsk
    RMAN-08500: channel incr0dsk: sid=12 devtype=DISK

    RMAN-03022: compiling command: backup
    RMAN-03023: executing command: backup
    RMAN-08008: channel incr0dsk: starting incremental level 0 datafile backupset
    RMAN-08502: set_count=21 set_stamp=415207572 creation_time=01-DEC-00
    RMAN-08010: channel incr0dsk: specifying datafile(s) in backupset
    RMAN-08522: input datafile fno=00003 name=/u03/oradata/fndry_p/rbs01.dbf
    RMAN-08522: input datafile fno=00006 name=/u04/oradata/fndry_p/indx01.dbf
    RMAN-08522: input datafile fno=00004 name=/u02/oradata/fndry_p/temp01.dbf
    RMAN-08522: input datafile fno=00007 name=/u05/oradata/fndry_p/migration01.dbf
    RMAN-08522: input datafile fno=00005 name=/u05/oradata/fndry_p/users01.dbf
    RMAN-08522: input datafile fno=00002 name=/u05/oradata/fndry_p/tools01.dbf
    RMAN-08522: input datafile fno=00008 name=/u03/oradata/fndry_p/txndata01.dbf
    RMAN-08522: input datafile fno=00010 name=/u03/oradata/fndry_p/txndata03.dbf
    RMAN-08522: input datafile fno=00012 name=/u03/oradata/fndry_p/txndata05.dbf
    RMAN-08522: input datafile fno=00014 name=/u03/oradata/fndry_p/refdata01.dbf
    RMAN-00571: ===========================================================
    RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
    RMAN-00571: ===========================================================
    RMAN-00601: fatal error in recovery manager
    RMAN-03004: fatal error during execution of command
    RMAN-10038: database session for channel incr0dsk terminated unexpectedly
    bash$ df .
    Filesystem 1k-blocks Used Available Use% Mounted on
    dffe01:/u01 52492612 3923048 45903084 8% /u07
    bash$ ls -l
    total 2873248
    -rw-r----- 1 oracle8i oracle8i 396100096 Dec 1 12:58 FNDRY_P_0icburd7
    -rw-r----- 1 oracle8i oracle8i 396100096 Dec 1 13:53 FNDRY_P_0kcbuuku
    -rw-r----- 1 oracle8i oracle8i 2147483647 Dec 1 15:31 FNDRY_P_0lcbv44k

  2. #2
    Join Date
    Jul 2000
    Posts
    50
    Try with this, though I have not tested this.

    RMAN> run {
    2> allocate channel incr0dsk type disk;
    3> allocate channel incr1dsk type disk;
    4> backup
    5> incremental level 0
    6> tag incr0_bkup
    7> format '/u07/tapebackup/tape0/fndry_p/%d_%u',
    8> '/u08/tapebackup/tape0/fndry_p/%d_%u'
    9> (database include current controlfile);
    10> release channel incr0dsk;
    11> }


    '/u08/tapebackup/tape0/fndry_p/%d_%u' : This is one more file system. Make sure that you have space to backup your data. If you need more space add one more channel and point to additional file location.

    regards,

    abhijit

  3. #3
    Join Date
    Nov 2000
    Posts
    205
    Thanks,

    I would prefer if I could just say break it up into files in the same place. Otherwise I would always have to calculate before backups and if my db is 2GB, I have to do this 10 times (if it works). RMAN is becoming such a pain.

    Thanks, if you think of anything let me know.

    Nirasha

  4. #4
    Join Date
    Jun 2000
    Posts
    295
    please use rman's set command:
    like
    set channel c1 kytes 2048000

  5. #5
    Join Date
    Nov 2000
    Posts
    205
    I have seen
    set limit channel ch1 kbytes 2097150;

    IS this what you are speaking of?

    Does this mean I have to estimate my total backup and divide by the OS filesize limit each time?

    Thanks for your help,
    Nirasha

  6. #6
    Join Date
    Oct 2000
    Posts
    34
    I belive, what if you use raw device you may be get over filesize limit.

  7. #7
    Join Date
    Jul 2000
    Posts
    50
    Yes, he meant that only. Limit the size of each channel and distribute it evenly to all location. You can also use "maxopenfiles" option. Add this two lines after channel alocation.

    setlimit channel incr0dsk 2048000 maxopenfiles 4;
    setlimit channel incr1dsk 2048000 maxopenfiles 4;

    Considered you have eightfiles to backup and max space reqd. by any four files is 2GB.

    Hope this will solve your problem.

    abhijit

  8. #8
    Join Date
    Nov 2000
    Posts
    205
    Yay, I got it.

    If I use the setsize parameter, it automatically sets each file size limit. Initially I thought of using it but the explanation in the guide/manual but a bit unclear.

    It works.. thanks all for help. I think I have learnt sooo much on RMAN now.

    Nirasha

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width