ORA-06553: PLS-707 occurs on log on via SQLPLUS
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 2 of 2

Thread: ORA-06553: PLS-707 occurs on log on via SQLPLUS

  1. #1
    Join Date
    Mar 2005
    Location
    south africa
    Posts
    2

    ORA-06553: PLS-707 occurs on log on via SQLPLUS

    Hi there - just to clarify my note - (a colleuge pointed out that is was a bit unclear - apologies)

    I apply the patchset using a ms-dos batch file to copy dll's , syms, plb's ect to the oracle home - the second part of the patch specifies that catalog, prvtexp, utlgdk need to be run on the database

    I did not get that far as to run the catalog and prvtexp scripts which was provided by the patch - the copying over of the new files (provided via the patchset) was not successfull !!!!

    So I replaced all copied files (dll's , syms, plbs, and sql) with the original ones.

    The odd thing is that I didn't run any scripts - just did a file copy.

    and now the error is occurring .......

    Grateful for any advice


    Hi all,

    I recently had to apply an Oracle patch (patchset 3820881) to 3 Oracle Instances (8.1.7.4)(these instances reside on the same server and use the same oracle home).

    During the copying over of the patch files - the following files were not copied over due to a process using them:
    oracore8.dll
    oranls8.dll
    oranro8.dll
    orantns8.dll
    orannzsbb8.dll
    oran8.dll
    orapls8.dll
    oraclient8.dll
    oracommon8.dll
    orageneric8.dll
    oranldap8.dll
    oranl8.dll
    oranbeq8.dll

    Before I copied the files provided with the patchset I created backups of the existing files - when I couldn't locate the process I copied the original files back. I did not run any scripts e.g (catexp, catalog or catproc ).
    I have since located the process that was monitoring/accessing them.

    However, the following error is encountered when I log in via a sqlplus session to 1 of the databases:

    "ERROR:
    ORA-06553: PLS-707: unsupported construct or internal error [2603]

    ERROR:
    ORA-06553: PLS-707: unsupported construct or internal error [2603]

    Error accessing package DBMS_APPLICATION_INFO[SIZE=1]"

    The error does not occur on the other databases!!!!

    I went onto metalink which suggested that catalog and catproc be run.
    I ran catalog and catproc - however none of the sys.packages are compiled and cannot be compiled via TOAD or Enterprise manager the following error occurs: (when I try compiling them)
    "ORA-04045: errors during recompilation/revalidation of SYS.ALL_OBJECTS
    ORA-00904: invalid column name"

    I did a search on this forum and a reply to a similar issue was to run catproc.sql, catalog.sql and dbmsstdx.sql (I checked and this recreates the standard package). However the situation involved relocating a database from one platform to another one -

    Is this still applicable to my situation even though no platform changes have occured (I mean no disrespect , I am just really nervous as I am just starting out as a dba and have no experience and I want to be sure before I go ahead and run anything that I am doing the right thing)

    Grateful if anyone can advise any further action I can take .. any advice would be highly appreciated
    Last edited by Luke; 03-17-2005 at 05:42 AM.

  2. #2
    Join Date
    Mar 2005
    Location
    south africa
    Posts
    2
    Turns out that the database wasn't properly upgraded from 8.1.6 .. in the first place and no one checks the database so I was the lucky one who did because of the patch install

    The appropriate scripts have been run and the error is gone

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width