Hello There,

I have tried to run rman from the catalog database server(adm_p) and tried to backup the database (fndry_p) to a directory on adm_p server. Both are unix servers. Below is my code and errors. The directory exists on adm_p and not on fndry_p (because I obviously don't want to backup my database to the same server). The error proves that it is looking at the target database. What should I do to make it look at adm_p???

Please help


RMAN> run {
2> allocate channel arch1 type disk;
3> sql 'alter system archive log current';
4> backup
5> format '/orahome/tapebackup/al_t%t_s%s_p%p'
6> (archivelog all);
7> release channel arch1;
8> }

RMAN-03022: compiling command: allocate
RMAN-03023: executing command: allocate
RMAN-08030: allocated channel: arch1
RMAN-08500: channel arch1: sid=9 devtype=DISK

RMAN-03022: compiling command: sql
RMAN-06162: sql statement: alter system archive log current
RMAN-03023: executing command: sql

RMAN-03022: compiling command: backup
RMAN-03025: performing implicit partial resync of recovery catalog
RMAN-03023: executing command: partial resync
RMAN-08003: starting partial resync of recovery catalog
RMAN-08005: partial resync complete
RMAN-03023: executing command: backup
RMAN-08009: channel arch1: starting archivelog backupset
RMAN-08502: set_count=7 set_stamp=414931458 creation_time=29-NOV-00
RMAN-08014: channel arch1: specifying archivelog(s) in backup set
RMAN-08504: input archivelog thread=1 sequence=33626 recid=1 stamp=414773941
RMAN-08504: input archivelog thread=1 sequence=33627 recid=2 stamp=414775981
RMAN-08504: input archivelog thread=1 sequence=33628 recid=3 stamp=414780171
RMAN-08504: input archivelog thread=1 sequence=33629 recid=4 stamp=414869382
RMAN-08504: input archivelog thread=1 sequence=33630 recid=5 stamp=414931456
RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-03007: retryable error occurred during execution of command: backup
RMAN-07004: unhandled exception during command execution on channel arch1
RMAN-10035: exception raised in RPC: ORA-19504: failed to create file "/orahome/tapebackup/al_t414931458_s7_p1"
ORA-27040: skgfrcre: create error, unable to create file
Linux Error: 2: No such file or directory
RMAN-10031: ORA-19624 occurred during call to DBMS_BACKUP_RESTORE.BACKUPPIECECREATE