Response action for alert is not executed(Oracle 10g)
DBAsupport.com Forums - Powered by vBulletin
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Response action for alert is not executed(Oracle 10g)

  1. #1
    Join Date
    Sep 2001
    Posts
    44

    Thumbs down Response action for alert is not executed(Oracle 10g)

    I have specified response action (a script file ) to be executed when alerts are generated for User defined metrics. Even though the alerts are generated the command line script is not getting executed. Could some one please help me.

    Thanks

  2. #2
    Join Date
    Sep 2002
    Location
    England
    Posts
    7,333
    did you press the on button?

  3. #3
    Join Date
    Sep 2001
    Posts
    44
    Originally posted by davey23uk
    did you press the on button?
    ON button? What is that ?Could you tell me more about it. I haven't heard of it. Thanks

    I have configured the alerts for user defined metrics using OEM.

    User Defined metrics
    http://download-west.oracle.com/docs....htm#sthref161
    Last edited by pradeepbha; 11-22-2004 at 07:03 AM.

  4. #4
    Join Date
    Sep 2002
    Location
    England
    Posts
    7,333
    i was being facetious.

    You provided no details of whats wrong except it doesnt work. People cant help if you provide no real details

  5. #5
    Join Date
    Sep 2001
    Posts
    44

    Thanks

    Originally posted by davey23uk
    i was being facetious.

    You provided no details of whats wrong except it doesnt work. People cant help if you provide no real details
    Thanks for the reply.

    Let me explain.

    I am trying to work on tablespace alert excercise mentioned in this article
    http://www.oracle.com/technology/obe...oring.htm#t1b.

    When setting up the threshold for the tablespace usage in the response action column I have specified an OS script to be executed so that I could take some corrective action.
    Reference :
    http://download-west.oracle.com/docs...e.htm#CBBDGAAA

    Even though the table space usage crossed the specified threshold no alerts got generated.


    Since the tablespace alert did not work , I tried with the User defined metrics rather than the tablespace usage. In case of user defined metrics, it is required to specify a table column which will be monitored target. If the column value crosses the specified threshold valued (I specified these values throught OEM) alerts will be generated.The alerts are getting generated for user defined metrics but the script is not executed. Which user the script run as ?

    Please Help.

  6. #6
    Join Date
    Sep 2002
    Location
    England
    Posts
    7,333
    have you set up preferred credentials?

  7. #7
    Join Date
    Sep 2001
    Posts
    44
    Originally posted by davey23uk
    have you set up preferred credentials?
    Yes I have done that.

  8. #8
    Join Date
    Aug 2002
    Location
    Atlanta
    Posts
    1,187
    Originally posted by pradeepbha
    Yes I have done that.
    what version and what user have you established preffered credentials with?
    I'm stmontgo and I approve of this message

  9. #9
    Join Date
    Sep 2001
    Posts
    44

    Thumbs up

    I was able to get the script executed. Initally I had given "/run.sh" as the response action but the script was not executed. I changed it to "sh /run.sh" and it worked.

    I am still not getting the tablespace usage alerts to be generated. Could someone help me.

    Thanks everyone for replies This is a good forum. Please continue the good work.

  10. #10
    Join Date
    Sep 2002
    Location
    England
    Posts
    7,333
    and yet you still provide no *actual* detail of the problem. Saying it doesnt work is no good to anyone

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width