12541 no listener ..error message i try to connect from sqlplus
DBAsupport.com Forums - Powered by vBulletin
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: 12541 no listener ..error message i try to connect from sqlplus

  1. #1
    Join Date
    May 2000
    Location
    maryland hights
    Posts
    20
    Hi i'm trying connect from sql plus i'm getting error message like ..no listener..but i can able to connect from telnet database is running fine can someone help me out.


    thanks you
    Nallamothu

  2. #2
    Join Date
    Jun 2000
    Posts
    295
    On client side, use tnsping first to see whether you can ping.
    On server side, use ps command to see whether listerner process is there.

  3. #3
    Join Date
    Nov 1999
    Posts
    226

    Wink

    Hi

    telnet to your server . Write LSNRCTL START and then your listener will start .
    Then you will be able to connect to your database..

    Inc ase any error , Let us know

  4. #4
    Join Date
    May 2000
    Location
    maryland hights
    Posts
    20
    [QUOTE][i]Originally posted by puneet [/i]
    [B]Hi

    telnet to your server . Write LSNRCTL START and then your listener will start .
    Then you will be able to connect to your database..

    Inc ase any error , Let us know [/B][/QUOTE]

    even i tnsping to db same error
    Nallamothu

  5. #5
    Join Date
    May 2000
    Location
    maryland hights
    Posts
    20
    hi listener is running still do i need to stop and start listener...

  6. #6
    Join Date
    Jun 2000
    Posts
    295
    Does not hurt to reload.

    lsnrctl-->reload-->status

    to see whether your ORACLE_SID is listed under
    your Services Summary...

  7. #7
    Join Date
    Mar 2000
    Location
    CA
    Posts
    317
    If you cannot TNSPING then may be problem with your network
    Thanks
    Kishore Kumar

  8. #8
    Join Date
    May 2000
    Location
    maryland hights
    Posts
    20
    i reload the listener eventhought it's not connect from sqlplus and i check the listenr process runnig
    ps -ef | grep tnslsnr ...it is fine,i try tnsping to db it says ..no listener.

    Nallamothu

  9. #9
    Join Date
    Oct 2000
    Location
    Dallas:TX:USA
    Posts
    407
    Make sure your service is using the same port to conenct to that listener is listening at.
    The default port is 1521 but there may be a chance that it's using some other port.

    - Rajeev

  10. #10
    Join Date
    Mar 2000
    Location
    westboro, ma, USA
    Posts
    14
    do you have a firewall between u'r machine and server ? In which case you need to open the port 1521 unless otherwise. Also check if u'r client is having multiple oracle home and the tnsnames is updated with the server you are connecting to.
    Rajesh

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width