PHP oracle OCI connect to Oracle 7
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 5 of 5

Thread: PHP oracle OCI connect to Oracle 7

Hybrid View

  1. #1
    Join Date
    Apr 2003
    Posts
    9

    PHP oracle OCI connect to Oracle 7

    Hi
    I'm writing a php script that connects to a Oracle 7 database using OCI.

    The login is successful, the function OCIServerVersion() returns the server version text correctly

    But when I perform a select statement, the data fetch is corrupted for example "<1-@"

    Below is my script

    $conn = OCILogon("lds","lds",$db);
    $stmt= ociparse($conn,"select * from tab ");
    $status=OCIExecute($stmt);
    $result = OCIresult($stmt,"TNAME");
    print $result;

    My Remote server is Oracle 7.2
    PHP version 4.2.3
    apache 1.3.12
    I installed Oracle9 on the local server
    OCI manages to login to the Oracle9 server and performs properly

    What could be wrong?

  2. #2
    Join Date
    Jan 2001
    Posts
    2,828
    Hi

    Try installing Oracle 7 on the local box from which ur running the php program and lets us know what happens.

    regards
    Hrishy

  3. #3
    Join Date
    Jul 2002
    Posts
    335
    Sorry, are you going from oracle 7 to oracle 9 (or vice versa)? If so, its unlikely to work, there is no net compatibility between the versions.

    Bazza

  4. #4
    Join Date
    Apr 2003
    Posts
    9
    hi Bazza
    I'm connecting from Oracle 9 to 7
    So I guess there is no compatibility??

  5. #5
    Join Date
    Jul 2002
    Posts
    335
    Originally posted by kennychw
    hi Bazza
    I'm connecting from Oracle 9 to 7
    So I guess there is no compatibility??
    correct

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width