BG process dying-question for pando,tamilselvan,wjramsay
DBAsupport.com Forums - Powered by vBulletin
Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: BG process dying-question for pando,tamilselvan,wjramsay

Hybrid View

  1. #1
    Join Date
    Jun 2000
    Posts
    104

    Red face

    why is this happenning occasionally I can see some bg processes like snp0,snp1 are dying ,sometimes shared server ,dispatchers getting dead.what 's happening??i can see the errors in alertlog.

    pl reply back,its urgent
    Share on Google+

  2. #2
    Join Date
    Jul 2000
    Location
    Oxford, OH
    Posts
    117
    Can you post the relevant error numbers and messages from the error log? Also, are any trace files written? Are there any patterns you are seeing like it is happening during a load, during the execution of a certain procedure, etc..

    Joe
    _________________________
    Joe Ramsey
    Senior Database Administrator
    dbaDirect, Inc.
    (877)687-3227
    Share on Google+

  3. #3
    Join Date
    Jun 2000
    Posts
    104
    found dead multi-threaded server 'S000', pid = (10, 1)
    Tue Nov 28 08:30:59 2000
    DBW0: terminating instance due to error 472
    Instance terminated by DBW0, pid = 165

    this is the message of alert log.No i cannot see any perticular procedure causing that.how can i trace that any procedure is causing it ?there r so many users.most of the times

    isee-
    restarting dead background process snp0

    this is the last statement in alert log,after this statement i can see i cannot connect to sql*plus.so most often snp are not getting started.do u want anything more??
    Share on Google+

  4. #4
    Join Date
    May 2000
    Location
    ATLANTA, GA, USA
    Posts
    3,136
    If you have configured MTS, then increase maximum number of servers, and dispatches in INIT.ORA file.
    Monitor the background processes using a shell script.
    Is your SGA size less than available memory?
    Share on Google+

  5. #5
    Join Date
    Jun 2000
    Posts
    104
    hi tamil,
    the no. of server proceses is 5,as no. of users are 24.dispatchers-3,do u think it is needed to increase this number.i am on NT,so how to trace actual cause of errors.
    sga size 370mb and ram 512 mb.what's the cause??pl reply back ,otherwise I will have to reinstall oracle.as this problem is causing lots of work to stop.how to monitor BG proceses on NT.
    Share on Google+

  6. #6
    Join Date
    Sep 2000
    Posts
    128
    What Version of Oracle, Patchsets, NT Service Packs?

    Update:
    I found quite a lot of hits on Metalink associated with this. There seems to be some known bugs on certain versions.

    On common piece of advice is to remove Dead Connection Detection from the sqlnet.ora file on the machine on which the instance is located:
    i.e. set:
    sqlnet.expire_time=0

    Are you getting any ORA-600 messages produced?

    [Edited by TerryD on 11-29-2000 at 04:45 AM]
    Share on Google+

  7. #7
    Join Date
    Jun 2000
    Posts
    104
    hi everybody,
    I increased the no.of servers to 7 as tamil said but constantly this error message is coming in alertlog-
    skgpspawn failed:category = 27143, depinfo = 9261, op = spdcr, loc = skgpspawn
    failed to start multi-threaded server 'S006', oer=27143
    whats the problem???
    its oracle 8.1.5 on NT 4.0 service pack 5.ora-600 I also saw in alertlog some days before,how to get rid of it?
    any patches??

    another thing -if at server i connect by giving scott/tiger I see ora-12560 tns protocol adapter error.

    but if I issue scott/tiger@orcl its getting connected.this is happenning occasionally,if i restart for sometime the problem gets solved ,but again after sometime it comes.

    thanks for all help.any suggestion is most welcome.
    Share on Google+

  8. #8
    Join Date
    Sep 2000
    Posts
    128
    Well, I found this on a link about a very similar problem:


    The ORA-600:[729] error is likely caused by a bug which effects 8.1.5 where a shared server process can encounter an ORA-600:[729] error when a process using database links disconnects. The bug is fixed in 8.1.6 and included in the 8.1.5.1 patchset release. The 8.1.5.1.1 patchset release for NT is available for download from the Patches option on MetaLink Home.

    I've also noticed a couple of other links relating to SP5.

    The common suggestion though is to set:

    sqlnet.expire_time=0

    in the sqlnet.ora file on the server, and see if that helps. The other suggestion is to raise a TAR with Oracle - I think they will come up with quite a few hits relating to this. Although you will need the whole ORA-600 message and any associated trace files.
    Share on Google+

  9. #9
    Join Date
    Jun 2000
    Posts
    104
    let me tell u this is workgroup server ,so pl tell me whats the limits of workgroup server,can i use any patch to overcome this error.
    but first tell whats diff betwn workgroup and enterprise edition,i know partitioning,transportable tbsp,index organized tables are not supported here.except these features if there is any limits set .

    some other errors in alertlog-
    Errors in file E:\ORACLE\admin\ORTELAPP\bdump\ortelappSNP1.TRC:
    ORA-00604: error occurred at recursive SQL level 1
    ORA-04030: out of process memory when trying to allocate 20 bytes (callheap,heap mark)
    skgpspawn failed:category = 27143, depinfo = 9261, op = spdcr, loc = skgpspawn
    failed to start dispatcher 'D002' for network '(ADDRESS=(PARTIAL=YES)(PROTOCOL=TCP))', oer=27143

    whats that memory error.
    Share on Google+

  10. #10
    Join Date
    May 2000
    Location
    ATLANTA, GA, USA
    Posts
    3,136
    Shortage of memory is your real problem.
    You should decrease the SGA size to 30-40% of RAM.
    Share on Google+

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width