DBAsupport.com Forums - Powered by vBulletin
Results 1 to 2 of 2
  1. #1
    Join Date
    May 2002

    Wrong Sysdate in the client

    I am using oracle 8.1.7 in Solaris. When I issued the sysdate command, it is returning two different value..

    From the local system, SQL*Plus client returns the correct date and time, compared to the local system clock. But when I run the same query from a remote SQL*Plus session returns the incorrect time

    I tried the following steps in my database:-

    Step 1 :-
    export ORACLE_SID=SID
    sqlplus user
    sql > select to_char(sysdate,'MM/DD/YY HH24:MI:SS') from dual;

    which sets up a local connection, I get the correct time.

    Step 2 :-
    In the same database server system, I connected to database by using @SID

    sqlplus user@SID
    Sql > select to_char(sysdate,'MM/DD/YY HH24:MI:SS') from dual;

    getting effectively a remote connection, I get the incorrect time.

    I restarted the listener, to make sure TZ variable in shell. But still I am spacing the same problem.

    Note :- I am sure that, I am connecting to same database server.
    Any help on this would be appreciated.

  2. #2
    Join Date
    Sep 2002
    sysdate get the time from the database server, presume you are on a unix variant - run the date command and compare it to select sysdate from dual

    also check v$instance to check you actually are connected to the same database, your tnsnames might redirect that SID to a different database

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Click Here to Expand Forum to Full Width

We have made updates to our Privacy Policy to reflect the implementation of the General Data Protection Regulation.