ora-01002 out of sequence when running report (business object)
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 3 of 3

Thread: ora-01002 out of sequence when running report (business object)

  1. #1
    Join Date
    Oct 2003

    ora-01002 out of sequence when running report (business object)

    Hi all,

    I have the db link from Oracle to sqlserver using ODBC. When we run Business object query from Oracle, it worked fine. When we run the query from Business Object via SQL server, it worked fine but when when run report to Oracle and from ORacle to Sqlserver to get the data, we got the errors ORA-01002 out of sequence. I did some research in Metalink and it said to set prefetch count =0 but that doesn't make sense b/c when Oracle bridge over sqlserver using SQLserver driver and there is no such thing where I can the prefetch count. Does anyone have any advises????


  2. #2
    Join Date
    Nov 2001
    review if you have a cursor and verify if have end loop condition.

  3. #3
    Join Date
    Nov 2000
    I know with a transparent gateway from Oracle-> DB2 you couldn't use cursors on remote databases for this reason.
    Jeff Hunter
    Get Firefox!
    "I pledge to stop eating sharks fin soup and will not do so under any circumstances."

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Click Here to Expand Forum to Full Width