OraHome92Agent service will not start.
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 4 of 4

Thread: OraHome92Agent service will not start.

  1. #1
    Join Date
    Jun 2004
    Location
    Kitsap Penninsula, Seattle WA
    Posts
    4

    Question OraHome92Agent service will not start.

    I've got a 9i database installed on my servers, I needed to change the host name of one machine, and broke the OraHome92Agent when I did. The error in the W2k log is "Agent process exited abnormally during initialization."

    I have made sure the new hostname is in
    ora92\network\agent\services.ora
    ora92\network\admin\tnsnames.ora
    ora92\network\admin\listener.ora

    and
    ora92\network\admin\snmp_ro.ora
    ora92\network\admin\snmp_rw.ora
    are created when I try to start the service.

    Any idea what I'm missing here? Everything else is running like a champ. Is there a way to reload the agent without reloding 9.2.0.x and patching?

    Thanks
    -MT

  2. #2
    Join Date
    Oct 2002
    Posts
    807
    Set up tracing and then look at your dbsnmp.log for errors.

  3. #3
    Join Date
    Jun 2004
    Location
    Kitsap Penninsula, Seattle WA
    Posts
    4
    I figured it out (actually, I logged a TAR) it has something to do with OEM, which I should have guessed.

    #1 Save all jobs and events against this node to the job library in OEM Console
    #2 De-register jobs and event against this node
    #3 Remove this node from the OEM console
    It may hang for awhile
    #4 Stop agent
    #5 Remove these files from the agents Oracle_Home
    O_H/network/agent/services.ora
    O_H/network/agent/*.q
    O_H/network/admin/snmp_ro.ora
    #6 Start agent
    #7 Discover node in OEM Console
    #8 Set preferred credentials
    #9 Register the jobs and events from the library

  4. #4
    Join Date
    Aug 2002
    Location
    Atlanta
    Posts
    1,187
    Originally posted by twood
    I figured it out (actually, I logged a TAR) it has something to do with OEM, which I should have guessed.

    #1 Save all jobs and events against this node to the job library in OEM Console
    #2 De-register jobs and event against this node
    #3 Remove this node from the OEM console
    It may hang for awhile
    #4 Stop agent
    #5 Remove these files from the agents Oracle_Home
    O_H/network/agent/services.ora
    O_H/network/agent/*.q
    O_H/network/admin/snmp_ro.ora
    #6 Start agent
    #7 Discover node in OEM Console
    #8 Set preferred credentials
    #9 Register the jobs and events from the library
    Listen, keep these steps handy for your next call to Oracle Support on EM and Agent Issues

    You : Agent is not working
    Oracle : Shutup reboot
    You : Yeah!!!!! Oracle has saved the day again!
    I'm stmontgo and I approve of this message

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width