I am new to Oracle Application Server. We have Oracle 9ias ver-
Whenever we change a report and put the latest .rep file and run it somehow it still picks the older version of the report, although it doesn't exist any where. I tried to clear the cache, but it didn't work. But when I restart the application server it picks up the new version of the report. I am not able to understand what might be the reason. Can anyone please put some light on this?

Here is an example incase I confused anyone above. Lets suppose I have a compiled report abc.rep(version 1 of report abc) under some directory called bin from where the reports are run. And for some reason the developers made changes to the report and a new version of abc.rep(version 2 of report abc) has replaced the older version. At this stage if no one has used that report abc after the application server was started then the new version gets picked and everything is fine. But if someone has used that report(version 1) lets say in the morning and it was replaced later in the afternoon by version 2, then it doesn't pick version 2 unless the application server is restarted. And there is no copy of the old version anywhere else on the server and I also tried clearing the cache. Any help would be appreciated.