Generating reports using RWServlet and Oracle Reports 6i
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 2 of 2

Thread: Generating reports using RWServlet and Oracle Reports 6i

Hybrid View

  1. #1
    Join Date
    Aug 2004
    Location
    Toronto, Canada
    Posts
    7

    Generating reports using RWServlet and Oracle Reports 6i

    I am trying to run reports using the RWServlet.class and Oracle Reports 6i, hitting an Oracle 8.1.7 database on Windows 2000. I am able to run the reports using my Allaire JRun web application by typing the url with the following format:

    http://my_webserver/servlet/RWServle...my_report.rdf+ USERID=username/password@my_db+DESFORMAT=html+DESTYPE=cache

    The reports run correctly, but, for those reports with a Runtime Parameter Form, the parameter form is not showing up, and the reports run without being able to modify the parameters. When I run the reports using the Reports Builder everything works OK.

    Is there a way to configure the reports to show the Runtime Parameter Form?

    Thanks in advance,

    Paul

  2. #2
    Join Date
    Aug 2004
    Location
    Toronto, Canada
    Posts
    7
    I found it.

    It was as simple as adding to the URL that invokes the report using the RWServlet.class the parameter &PARAMFORM=YES, which means show the Parameter Form at runtime.

    Paul

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width