Where to download components required for Oracle 9iR2 on RHEL AS 3.0
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 6 of 6

Thread: Where to download components required for Oracle 9iR2 on RHEL AS 3.0

  1. #1
    Join Date
    Sep 2003
    Location
    China
    Posts
    72

    Where to download components required for Oracle 9iR2 on RHEL AS 3.0

    I have been searching the web and did not find some of the rpm which are required for RHEL before I can install Oracle 9.2.0.1. Pls provide some good URL for me to download those RPMs. Thks!

  2. #2
    Join Date
    Jan 2004
    Posts
    58

    Question re : what is RHEL and RPM

    hi! ,

    I am junior member ..

    Could you please elaborate on what RHEL and RPM are ???

    thanks,
    harish
    thanks,
    harish

  3. #3
    Join Date
    Sep 2003
    Location
    China
    Posts
    72

    Re: re : what is RHEL and RPM

    Originally posted by hreddy007
    hi! ,

    I am junior member ..

    Could you please elaborate on what RHEL and RPM are ???

    thanks,
    harish

    RHEL - Red Hat Enterprise Linux

    RPM - RPM Package Manager in Linux to handle applications installation

  4. #4
    Join Date
    Sep 2003
    Location
    China
    Posts
    72
    I found those RPMs but now I have problem installing

    compat-gcc-7.3-2.96.122.i386.rpm. See error below. I have also downloaded

    glibc-devel-2.3.2-27.9.7.i386.rpm. Now do I need

    glibc-kernheaders-2.4-8.34.i386.rpm? Oracle install doc does not list those RPM... just want to double confirm.
    [root@backup2 root]#
    [root@backup2 root]# rpm -iv compat-gcc-7.3-2.96.122.i386.rpm
    error: Failed dependencies:
    glibc-devel is needed by compat-gcc-7.3-2.96.122
    Suggested resolutions:
    glibc-devel-2.3.2-95.3.i386.rpm
    [root@backup2 root]#
    [root@backup2 root]# rpm -iv glibc-devel-2.3.2-27.9.7.i386.rpm
    warning: glibc-devel-2.3.2-27.9.7.i386.rpm: V3 DSA signature: NOKEY, key ID

    db42a60e
    error: Failed dependencies:
    kernel-headers is needed by glibc-devel-2.3.2-27.9.7
    kernel-headers >= 2.2.1 is needed by glibc-devel-2.3.2-27.9.7
    Suggested resolutions:
    glibc-kernheaders-2.4-8.34.i386.rpm
    [root@backup2 root]#

  5. #5
    Join Date
    Jan 2000
    Posts
    387
    Hi

    You will need the following packages for installation of 9iR2 on RHEL3:

    compat-db-4.0.14-5.i386.rpm \
    compat-gcc-7.3-2.96.122.i386.rpm \
    compat-gcc-c++-7.3-2.96.122.i386.rpm \
    compat-libstdc++-7.3-2.96.122.i386.rpm \
    compat-libstdc++-devel-7.3-2.96.122.i386.rpm
    openmotif21-2.1.30-8.i386.rpm \
    setarch-1.3-1.i386.rpm \
    tcl-8.3.5-92.i386.rpm

    I have encountered an error with the binutils during the installation, therefore I have downgraded it from 2.14 to 2.13 and it should installed Oracle 9iR2 successfully after this.

  6. #6
    Join Date
    Sep 2003
    Location
    China
    Posts
    72
    Yes with

    compat-db-4.0.14-5.i386.rpm \
    compat-gcc-7.3-2.96.122.i386.rpm \
    compat-gcc-c++-7.3-2.96.122.i386.rpm \
    compat-libstdc++-7.3-2.96.122.i386.rpm \
    compat-libstdc++-devel-7.3-2.96.122.i386.rpm
    openmotif21-2.1.30-8.i386.rpm \
    setarch-1.3-1.i386.rpm \
    tcl-8.3.5-92.i386.rpm

    I encountered the above errors when installing compat-gcc-7.3-2.96.122.i386.rpm

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width