lower compatible parameter
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 9 of 9

Thread: lower compatible parameter

  1. #1
    Join Date
    Jan 2000
    Posts
    387

    lower compatible parameter

    Hi

    I did the following :

    alter system set compatible='8.1.7' scope=spfile;

    when i start up the database again, i got the following error:

    ORA-00402: database changes by release 9.2.0.0.0 cannot be used by release
    8.1.7.0.0
    ORA-00405: compatibility type "Locally Managed SYSTEM tablespace"

    How do i set the compatible parameter to a lower version??

  2. #2
    Join Date
    Dec 2000
    Location
    Ljubljana, Slovenia
    Posts
    4,439
    You won't be able to set the compatible parameter to 8.1.7 for this 9.2 database, because your SYSTEM tablespace is localy managed, which is not supported by pre-9i releases. So unless you rebuild your database from scratch with system tablespace defined as dictionary managed, you will only be able to set your compatibility as far as 9.0 - no lower than that will be possible.
    Jurij Modic
    ASCII a stupid question, get a stupid ANSI
    24 hours in a day .... 24 beer in a case .... coincidence?

  3. #3
    Join Date
    Jan 2000
    Posts
    387
    How do i import my database 8.1.7 into the version 9.2.0.4 since the managed tablespace are different?

  4. #4
    Join Date
    Oct 2002
    Posts
    807
    Create all tablespaces as LMT in 9i. Import with IGNORE=Y. That will do it.

  5. #5
    Join Date
    Aug 2002
    Location
    Colorado Springs
    Posts
    5,253
    Originally posted by mooks
    How do i import my database 8.1.7 into the version 9.2.0.4 since the managed tablespace are different?
    There's a section on inter-version exp/imp compatability in the Utilities Guide. http://tahiti.oracle.com
    David Aldridge,
    "The Oracle Sponge"

    Senior Manager, Business Intelligence Development
    XM Satellite Radio
    Washington, DC

    Oracle ACE

  6. #6
    Join Date
    Jan 2000
    Posts
    387
    I did that, but i encountered those errors which I have posted in my first message... which i thought was an compatible parameter issue?? Any help please?

  7. #7
    Join Date
    Jan 2000
    Posts
    387
    I have checked that the migration is a direct path from 8.1.7 to 9.2.0.4. However I am encountering the errors upon import. Did i miss out any steps??

  8. #8
    Join Date
    Oct 2002
    Posts
    807
    Create all tablespaces as LMT in 9i. Import with IGNORE=Y. That will do it.
    I did that, but i encountered those errors which I have posted in my first message... which i thought was an compatible parameter issue?? Any help please?
    Post error messages after you pre-created the LMT in 9i and issued an import with IGNORE=Y. I've done this in the past with no problems whatsoever.

  9. #9
    Join Date
    Jan 2000
    Posts
    387
    Thanks for the reply. I have sone the same import before too. The only difference now is the OS platform which i do not think could be of a problem...

    Anyway, it is advisable to use local managed tablespace right? Therefore is it better if i re-create all the tablespace than to do the import full? Please advice...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width