sample_io (catio.sql) question
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 4 of 4

Thread: sample_io (catio.sql) question

  1. #1
    Join Date
    Oct 2002
    Location
    Breda, The Netherlands
    Posts
    317

    sample_io (catio.sql) question

    Hi guys,

    I'm trying to get some info on the IO per object, so I installed catio.sql.
    Next I ran "exec sample_io(5,60);" a few times at busy and not-so-busy moments. But when I look at the result-view "IO_PER_OBJECT", I always get the same result:
    Code:
    SQL> select * from sys.io_per_object;
    
    NAME             PARTITION_NAME  KIND             IO_TYPE              BLOCKS_READ
    ---------------- --------------- ---------------- -------------------- -----------
    C_TS#                            CLUSTER          sequential                     1
    Database: 8.1.7.0.0 on Wi(n)dows 2000 Adv.Server
    Buffer cache:
    Code:
    SQL> select * from vw_ideal_buffer_cache ;
    
    DATE     BUFFER_POOL        CURRENT      IDEAL
    -------- --------------- ---------- ----------
    ...
    13-04-04 DEFAULT               8192       7256
    I think I'm following the correct procedure... How must I interpret this info?

    I hope someone can help me...
    Last edited by efrijters; 04-13-2004 at 11:19 AM.
    An expert is one who knows more and more about less and less until he knows absolutely everything about nothing.

  2. #2
    Join Date
    Nov 2000
    Location
    greenwich.ct.us
    Posts
    9,092
    I've never had any luck with catio. As far as I remember, you're pulling stuff off the backend of the LRU. This inherently under-reports objects that are used quite frequently. There are a couple of notes on metalink that explain it, although I can't put my browser on a good one right now...
    Jeff Hunter
    marist89@yahoo.com
    http://marist89.blogspot.com/
    Get Firefox!
    "I pledge to stop eating sharks fin soup and will not do so under any circumstances."

  3. #3
    Join Date
    Oct 2002
    Location
    Breda, The Netherlands
    Posts
    317
    Whoops... Metalink mentions more errors in the procedure :

    In the declare-section of 'sample_io' I already altered
    tail_of_lru raw(4);
    this_tail_of_lru raw(4);

    into
    tail_of_lru raw(8);
    this_tail_of_lru raw(8);


    and now I altered:
    tail_of_lru := hextoraw('4000000000'); -- init to very large value
    into
    tail_of_lru := hextoraw('ffffffff'); -- init to very large value

    I'll test again and post results...
    An expert is one who knows more and more about less and less until he knows absolutely everything about nothing.

  4. #4
    Join Date
    Oct 2002
    Location
    Breda, The Netherlands
    Posts
    317
    Well... that bug-fix was a big improvement: going from 1 result row to zero rows

    I just tested it for 10 minutes with a 60 second interval, but view io_per_object returns nothing, nada, niente... Grrrr!

    [possible explanation]
    Maybe my buffer cache is big enough and no data was kicked out during the sampling... My buffer cache is probably well-tuned
    [/possible explanation]

    Is there another way to monitor I/O at object-level?

    PS: thanks Marist89 for your reply!
    Last edited by efrijters; 04-13-2004 at 11:21 AM.
    An expert is one who knows more and more about less and less until he knows absolutely everything about nothing.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width