SQL Plus setup
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 10 of 10

Thread: SQL Plus setup

  1. #1
    Join Date
    Nov 2000
    Location
    Birmingham, UK
    Posts
    360

    SQL Plus setup

    I've got something a bit screwy with my SQL Plus setup (at least thats what I think it is) For some reason I cant run scripts using the @ symbol:

    i.e.
    SQL> @crdb_minepw01_version9.sql
    SP2-0734: unknown command beginning "crdb_minep..." - rest of line ignored.

    Using Oralce 9.2.0.4 - Can anyone suggest anything?

    Cheers,
    Fraze

  2. #2
    Join Date
    Sep 2002
    Location
    England
    Posts
    7,333
    what os?

  3. #3
    Join Date
    Apr 2003
    Posts
    353
    have u tried
    RUN
    command

  4. #4
    Join Date
    Nov 2000
    Location
    Birmingham, UK
    Posts
    360
    O/S is HP-UX 11.11 - I can still run the get and run commands OK but I've got a big DB creation script that calls lots of other scripts using "@" and I dont want to manually have to get and run loads of different scripts
    Its the same for all the 9204 DB's on the server - could it be a UNIX env variable or something? Have compared with a server that is OK and the $PATH, $LIB env variables etc seem to be fine.

  5. #5
    Join Date
    Nov 2002
    Location
    Geneva Switzerland
    Posts
    3,142
    Does START work:
    START crdb_minepw01_version9.sql
    From the SQL*Plus manual:
    "If the START command is disabled (see "Disabling SQL*Plus, SQL, and PL/SQL Commands" in Appendix E), this will also disable the @ command."

    Have you set @ to be the escape char by accident?
    What happens if you:
    SET ESC OFF

  6. #6
    Join Date
    Sep 2002
    Location
    England
    Posts
    7,333
    stty erase "^H" kill "^U" intr "^C" eof "^D"
    stty hupcl ixon ixoff


    set these in your .profile

    whats happening is that the @ is being folowed by a carriage return

  7. #7
    Join Date
    Nov 2000
    Location
    Birmingham, UK
    Posts
    360
    Thanks for the replies - its seems like daveys solution has worked - thanks again

  8. #8
    Join Date
    Sep 2002
    Location
    England
    Posts
    7,333
    just to clarify, those are hpux specific things and had me cursing for a long time before finding the answers

  9. #9
    Join Date
    Nov 2000
    Location
    Birmingham, UK
    Posts
    360
    I know the feeling! It was driving me round the bend - much appreciated!

  10. #10
    Join Date
    Nov 2000
    Location
    Birmingham, UK
    Posts
    360
    Davey23uk,

    Got another nagging problem once I've set these commands. Have set stty erase ^? (instead of ^H for my emulator) and can use backspace in UNIX, but when I login to SQL*Plus and do

    SQL>sdsd
    then
    SP2-0042: unknown command "sd" - rest of line ignored.
    SQL>

    Probably not the best example in the world, but it appears that the screen isnt being updated even though SQL Plus knows that two characters have been deleted. Any ideas?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width