DBAsupport.com Forums - Powered by vBulletin
Results 1 to 5 of 5
  1. #1

    ORA-12571 TNS Packet Writer Failure out of the blue

    As of a month ago I have recieved two or three dozen complaints from a cross section of 30-40 clients, all of which are either running Oracle or oracle 9.2 databases with oracle 8.1.6 and oracle 9.2 clients respectively. The complaints are always the same. Everything was working fine and I went to open the appliation and recieved a fatal error.

    ORA-12571 TNS Packet Writer Failure

    The application is a client/server records management program written in Delphi for Windows 98, 2k and XP clients and NT, 2000 and 2003 server environments.

    Usually, out of 30-50 computers 1 or 2 may be affected by this problem. And on a seemingly random basis. Restarting the database or cycling the entire network doesn't resolve the problem, uninstalling all service packs and hotfixes and even reinstalling the oracle client software completely after deleting all directories and registry keys also does not resolve the problem. No other computers are affected and the ONLY way I have been able to resolve this error is by reformatting the computer and reinstalling the operating system. Any suggestions would be greatly appreciated.

    A TNSPING SERVICENAME from the dos prompt results in the same error message, both before and after reinstalling oracle.

    It is my understanding that the Operating System (windows) is not allowing the oracle client to communicate on port 1521 because it feels that this port is a security vulnerability. Can anyone else shed some additional light on this problem?
    Chester Ney
    CODY Computer Services
    System DBA

  2. #2
    Just an FYI, running SPYBOT Search and Destroy resolved this problem. Apparently there was some spyware on the machines that were expiriencing the problem that were monitoring or restricting access to port 1521. After running SPYBOT everything worked normally.
    Chester Ney
    CODY Computer Services
    System DBA

  3. #3
    Join Date
    Nov 2000
    Jeff Hunter
    Get Firefox!
    "I pledge to stop eating sharks fin soup and will not do so under any circumstances."

  4. #4
    Very nice... Unfortunately... linux is not an option here...
    Chester Ney
    CODY Computer Services
    System DBA

  5. #5
    Join Date
    Feb 2006
    There may be a problem with your Windows Sockets. Try to run WinSock XP Fix. You can download this tool on http://www.webattack.com/get/winsockxpfix.html. I've had the same problem and this tool solved it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Click Here to Expand Forum to Full Width

We have made updates to our Privacy Policy to reflect the implementation of the General Data Protection Regulation.