Unable to configure a new LISTENER - Urgent
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 2 of 2

Thread: Unable to configure a new LISTENER - Urgent

  1. #1
    Join Date
    Oct 2005
    Posts
    7

    Unable to configure a new LISTENER - Urgent

    HI All,
    Iam trying to create a listener to connect to an already existing instance. I did the following to realize it....

    1) Made an entry in Listener.ora file.. ie appended to an already existing listener configuration.. The contents of listener.ora file is as below..
    ******************* LISTENER.ORA - Starts ***************************************************************
    # LISTENER.ORA Network Configuration File: C:\oracle\ora92\network\admin\listener.ora
    # Generated by Oracle configuration tools.

    LISTENER =
    (DESCRIPTION_LIST =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC0))
    )
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = TCP)(HOST = your-bb6a36c020)(PORT = 1521))
    )
    )
    )

    SID_LIST_LISTENER =
    (SID_LIST =
    (SID_DESC =
    (SID_NAME = PLSExtProc)
    (ORACLE_HOME = C:\oracle\ora92)
    (PROGRAM = extproc)
    )
    (SID_DESC =
    (GLOBAL_DBNAME = PLATO_GD)
    (ORACLE_HOME = C:\oracle\ora92)
    (SID_NAME = PLATO)
    )
    )

    ------------------- Append Starts - 2nd Listener will listen on port 1522 ------------------------------
    LISTENER2 =
    (DESCRIPTION_LIST =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC0))
    )
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = TCP)(HOST = your-bb6a36c020)(PORT = 1522))
    )
    )
    )

    SID_LIST_LISTENER2 =
    (SID_LIST =
    (SID_DESC =
    (SID_NAME = PLSExtProc)
    (ORACLE_HOME = C:\oracle\ora92)
    (PROGRAM = extproc)
    )
    (SID_DESC =
    (GLOBAL_DBNAME = PLATO_GD)
    (ORACLE_HOME = C:\oracle\ora92)
    (SID_NAME = PLATO)
    )
    )
    ------------------- Append Ends ------------------------------
    ******************* LISTENER.ORA - Ends *************************

    2) After making the above entry I started the LISTENER2 and tried to connect to instance PLATO. Even though the Listener2 started I was unable to connect to instance becoz of error "ORA-12541: TNS:no listener".
    The listener2 startup log is as below....

    ********** LISTENER2 - Startup LOG *******************************
    C:\Documents and Settings>lsnrctl

    LSNRCTL for 32-bit Windows: Version 9.2.0.1.0 - Production on 03-FEB-2006 16:59:
    45

    Copyright (c) 1991, 2002, Oracle Corporation. All rights reserved.

    Welcome to LSNRCTL, type "help" for information.

    LSNRCTL> start LISTENER2
    Starting tnslsnr: please wait...

    Failed to open service , error 1060.
    TNSLSNR for 32-bit Windows: Version 9.2.0.1.0 - Production
    System parameter file is C:\oracle\ora92\network\admin\listener.ora
    Log messages written to C:\oracle\ora92\network\log\listener2.log
    Listening on: (DESCRIPTION=(ADDRESS=(PROTOCOL=ipc)(PIPENAME=\\.\pipe\EXTPROC0ipc
    )))
    Listening on: (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=your-bb6a36c020)(PORT=15
    22)))

    Connecting to (DESCRIPTION=(ADDRESS=(PROTOCOL=IPC)(KEY=EXTPROC0)))
    STATUS of the LISTENER
    ------------------------
    Alias LISTENER2
    Version TNSLSNR for 32-bit Windows: Version 9.2.0.1.0 - Produc
    tion
    Start Date 03-FEB-2006 17:01:13
    Uptime 0 days 0 hr. 0 min. 2 sec
    Trace Level off
    Security OFF
    SNMP OFF
    Listener Parameter File C:\oracle\ora92\network\admin\listener.ora
    Listener Log File C:\oracle\ora92\network\log\listener2.log
    Listening Endpoints Summary...
    (DESCRIPTION=(ADDRESS=(PROTOCOL=ipc)(PIPENAME=\\.\pipe\EXTPROC0ipc)))
    (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=your-bb6a36c020)(PORT=1522)))
    Services Summary...
    Service "PLATO_GD" has 1 instance(s).
    Instance "PLATO", status UNKNOWN, has 1 handler(s) for this service...
    Service "PLSExtProc" has 1 instance(s).
    Instance "PLSExtProc", status UNKNOWN, has 1 handler(s) for this service...
    The command completed successfully
    LSNRCTL>

    ********** LISTENER2 - Startup LOG - ENDS *******************************


    3) Also, I am able to connect to instance successfully using the already configured listener.

    Can anyone help me in this? Please let me know where am I misssing.

    Thanks in advance..

  2. #2
    Join Date
    Oct 2005
    Posts
    7
    Hi All,
    The issue got resolved. The tnsnames.ora was not reflecting the right listener port. Upon changing it Iam able to connect now.

    Thanks A Lot..

    Bye

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width