sqlplus failed to start
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 5 of 5

Thread: sqlplus failed to start

Hybrid View

  1. #1
    Join Date
    Oct 2002
    Posts
    391

    sqlplus failed to start

    i started mysqlpus '/ as sysdba' then get the below


    exec(): 0509-036 Cannot load program sqlplus because of the following errors:
    0509-130 Symbol resolution failed for /usr/lib/libc.a[aio_64.o] because:
    0509-136 Symbol kaio_rdwr64 (number 0) is not exported from
    dependent module /unix.
    0509-136 Symbol listio64 (number 1) is not exported from
    dependent module /unix.
    0509-136 Symbol acancel64 (number 2) is not exported from
    dependent module /unix.
    0509-136 Symbol iosuspend64 (number 3) is not exported from
    dependent module /unix.
    0509-136 Symbol aio_nwait (number 4) is not exported from
    dependent module /unix.
    0509-150 Dependent module libc.a(aio_64.o) could not be loaded.
    0509-026 System error: Cannot run a file that does not have a valid form
    at.
    0509-192 Examine .loader section symbols with the
    'dump -Tv' command.



    a search in goggle prompt me to check my aio.. indeed, it was not available. so i have to change it and restart it.

    1) is there any way to change the aio status other than restart the box?

    2) what are the error messages linked to aio?

    thanks

  2. #2
    Join Date
    Feb 2001
    Location
    Adelaide, Australia
    Posts
    159
    If you really do not wish to reboot, you could change the database init.ora parameter disk_asynch_io to FALSE to disable the use of asynchronous I/O within the database. You can simulate Asynchronous I/O by adding DBWRs.
    Check this link for details:
    http://metalink.oracle.com/metalink/...T&p_id=47328.1
    .
    However, I would strongly advise you to take advantage of aio and reboot if necessary.
    Your questions on aio and rebooting the server are probably better suited to a UNIX forum somwhere.
    .
    Brgds,
    Andy

  3. #3
    Join Date
    May 2001
    Posts
    41
    the Oracle Home have not been set on unix environment.

    Please set the Oracle_home on unix environment and export it.

    then it works.

  4. #4
    Join Date
    Feb 2004
    Posts
    50
    1) is there any way to change the aio status other than restart the box?

    2) what are the error messages linked to aio?
    It depends on your operating system and Oracle version.

    A new Oracle install on AIX 64 bit mode perhaps?

  5. #5
    Join Date
    Oct 2002
    Posts
    391
    Originally posted by rameshgiri26
    the Oracle Home have not been set on unix environment.

    Please set the Oracle_home on unix environment and export it.

    then it works.
    is this really the root cause? i did a reboot and everything is fine.

    If you really do not wish to reboot, you could change the database init.ora parameter disk_asynch_io to FALSE to disable the use of asynchronous I/O within the database. You can simulate Asynchronous I/O by adding DBWRs.
    Check this link for details:
    http://metalink.oracle.com/metalink...OT&p_id=47328.1
    .
    However, I would strongly advise you to take advantage of aio and reboot if necessary.
    Your questions on aio and rebooting the server are probably better suited to a UNIX forum somwhere.
    .
    Brgds,
    Andy
    can u post that note here?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width