IMP Command not found
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 4 of 4

Thread: IMP Command not found

  1. #1
    Join Date
    Sep 2000
    Location
    VA
    Posts
    343

    IMP Command not found

    Hi all, I am on a Solaris machine on Bash prompt where I am getting an "IMP command not found" error under the Oracle directory. I am not a Unix person - Is this error because of the shell that I am in or is there something missing in Oracle that I need to look into ?

    Thanks.

  2. #2
    Join Date
    Oct 2000
    Location
    Germany
    Posts
    1,185
    You might need to set the $PATH variable.
    David Knight
    OCP DBA 8i, 9i, 10g

  3. #3
    Join Date
    Sep 2002
    Location
    England
    Posts
    7,333
    best option is to in you .bashrc do:

    export ORACLE_HOME=/u01/app/oracle/product/9.2.0 (for example)
    export PATH=$ORACLE_HOME/bin:$PATH
    export LD_LIBRARY_PATH=$ORACLE_HOME/lib:$LD_LIBRARY_PATH

    Then to see if you have imp in you path do:

    which imp

    and it should tell you where it is.

    If you can use ksh, best option for Solaris

  4. #4
    Join Date
    Sep 2000
    Location
    VA
    Posts
    343
    Thanks for all your responses. I basically needed to use a different username and now all the paths are getting set automatically.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width