Hi guys! I've read al your thread from top to bottom. I was having the exact same annoyance. I'll tell a long story short about my problem:

Today I was called from our branch at Spain. They used to have a local DBA but there resource was to expensive, so whatta'heck... lets give the DBA to the Argentine DBA Team... (sounds like a bunch but it's just my boss and me).

It turns out the DB in question was(is) running over a Windows 2003. We are talking about a Oracle Server.

The database holds a META4 application and that's about it. The thing is I was mailed today by an IT Manager from spain saying the they had to "fix" the database by restarting both: The Application Server (META4) and the Win2k3 that holds the Oracle. I got kindda pist off because those are the things that I believe, one never does... the last thing you wanna try as a workaround is a warm restart.

So, after a while measuring this and that (they also said it was kindda slow) I go RDP to the win2k3, to go take a look at the Alert_$SID.log.... Woops... where is it? --> select * from v$parameter where name like '%dump%'. Yeap there it is = background_dump_dest=D:\ORACLE\PRODUCT\10.2.0\ADMIN\ORAM4B\BDUMP

Alertlog Last modified like 2 months ago... Darn!... How can that be! so I issued the switch logfile... no modification yet... I shutdown immediate (on maintenance window), startup again... nothing!!

I change the destination paths:

alter system set background_dump_dest='D:\' scope=both;

Okay... I tried a lot of things all mixed up... my bad!.

So the things I tried were:

-->File access and attributes(discovered that oracle sets the udump cdump bdump folders to Read-Only folders!!) Everything OK there
-->Changed destination folders!... Nothing happened
-->Changed static parameters for the PFILE ... Nothing happened
-->Many other stupid things as I was hopeless.
-->Last thing I try is set the database to startup from an SPFILE the same as the above mentioned.
-->Startup mount pfile='spfilainit.ora' (flat file containing "spfile='spfilepath.ora'" (noquotes)
-->Intance started alright... and then issued:
-->Alter system set background_dump_dest='D:\ORACLE\PRODUCT\10.2.0\ADMIN\ORAM4B\BDUMP' scope=both;

System altered.

And guess what??

The SOAB appeared again!

so just in case I did another logfile switch, and for my blessing... this AlertSID.log was working just fine!

I hope this helps anyone... So what's with the alertlog and the SPFILE?