I get Unable to initialize threads: cannot fine class java/lang/Thread error
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 2 of 2

Thread: I get Unable to initialize threads: cannot fine class java/lang/Thread error

  1. #1
    Join Date
    Oct 2003
    Location
    Irving
    Posts
    3

    I get Unable to initialize threads: cannot fine class java/lang/Thread error

    Hi,
    I have installed Linux 9 on my laptop and was trying to install Oracle 8.1.7.
    I have extracted the tar file into /home/oracle/src/Disk1 and when I run ./runInstaller then I get the following message.

    Initializing Java Virtual Machine from
    ../stage/Components/oracle.swd.jre/1.1.8/1/DataFiles/Expanded/linux/bin/jre.
    Please wait...
    /home/oracle/src/Disk1/stage/Components/oracle.swd.jre/1.1.8/1/DataFiles/Expanded/linux/lib/linux/native_threads/libzip.so:
    symbol errno, version GLIBC_2.0 not defined in file
    libc.so.6 with link time reference (libzip.so)
    Unable to initialize threads: cannot find class
    java/lang/Thread
    Could not create Java VM

    I don't know how to even proceed with such an error.
    I never worked on a Linux much.

    My .bash_profile file has the following contents.

    PATH=$PATH:$HOME/bin
    export PATH
    unset USERNAME
    ORACLE_BASE=/u01/app/oracle; export ORACLE_BASE
    ORACLE_HOME=/u01/app/oracle/product/8.1.7; export
    ORACLE_HOME
    ORACLE_SID=ora1; export ORACLE_SID
    PATH=$PATH:/u01/app/oracle/product/8.1.7/bin; export
    PATH
    CLASSPATH=.:/u01/app/oracle/product/8.1.7/jdbc/lib/classes111.zip;
    export CLASSPATH
    LD_LIBRARY_PATH=/u01/app/oracle/product/8.1.7/lib;
    export LD_LIBRARY_PATH
    umask 022
    ORA_NLS33=/u01/app/oracle/product/8.1.7/ocommon/nls/admin/data;
    export ORA_NLS33
    NLS_LANG=american; export NLS_LANG

    I have copied a file jdk118_v3-glibc-2.1.3.tar.bz2 to /usr/local directory and extracted it to /usr/local/jdk118_v3 directory.
    Do I need to give CLASSPATH as /usr/local/jdk118_v3?

    I would appreciate if any one can give feedback in this.
    Thanks in advance
    Raghavendra

  2. #2
    Join Date
    Oct 2000
    Location
    Saskatoon, SK, Canada
    Posts
    3,925
    Looks like your libc is causing the issue.

    download a JRE latest version, install on /usr/local/java, and edit '/install/oraparam.ini', change the JRE location, and run the 'runInstaller' from '/install/linux'.

    Sam
    Last edited by sambavan; 10-24-2003 at 06:42 PM.
    Thanx
    Sam



    Life is a journey, not a destination!


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width