database link problem
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 4 of 4

Thread: database link problem

  1. #1
    Join Date
    Apr 2003
    Location
    Rosmalen, Netherlands.
    Posts
    73

    database link problem

    Hi,

    I encountered a db-link problem;

    When I create a db-link as sys on the first database using the following script ( to access the second database on the same server) ;

    CREATE PUBLIC DATABASE LINK "DBname"
    CONNECT TO "user"
    IDENTIFIED BY "********"
    USING 'Second Database'

    I try to connect to by this link using SQL*PLUS the error ORA-00942 pops up. This probably indicates this is a privileges issue but what privs do I have to set ( and on which database ) to connect to the second database.

    select count(*) from DBname.table;

    Please push me in the right direction.

    GKramer

  2. #2
    Join Date
    Sep 2002
    Location
    England
    Posts
    7,331
    select count(*) from table@dbname

  3. #3
    Join Date
    Apr 2003
    Location
    Rosmalen, Netherlands.
    Posts
    73
    davey23uk

    NO COMMENT ...... ( I'm embarressed ( haven't used it for a long time ) )...

    Thanks anyway.

    GKramer

  4. #4
    Join Date
    Dec 2002
    Location
    Bangalore ( India )
    Posts
    2,434

    Re: database link problem

    Originally posted by GKramer
    select count(*) from DBname.table;
    Lemme giv some tip here, OBJECT_NAME1.OBJECT_NAME2 will mean SCHEMA.OBJECT_NAME...
    funky...

    "I Dont Want To Follow A Path, I would Rather Go Where There Is No Path And Leave A Trail."

    "Ego is the worst thing many have, try to overcome it & you will be the best, if not good, person on this earth"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width