Database startupp in NT
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 6 of 6

Thread: Database startupp in NT

  1. #1
    Join Date
    Sep 2000
    Posts
    4

    Unhappy

    Hi,
    I have a problem in starting the database in NT. I shutdown the database using OEM Instance manager and the database went down normally. I tried restarting the database and got 'TNS: unable to connect to destination'. So i stopped and restarted the listener and tried staring the database. This also didn't work. Then I checked the tnsnames.ora and listener.ora for the entries. Everything seems to be fine. listener also gets started. When I tried to start the database from 'svrmgrl30' it says 'cannot connect to destination'. I tried different options like replacing the hostname with the original IP address and the listener comes up fine. All the jobs i tried was not as an oracle user. So should I have an oracle user created on NT and try using that account? Even then what is the relation between server manager and TNS destination? Is there any default password for connecting to Internal?

    Thanks,
    sriram

  2. #2
    Join Date
    Mar 2000
    Location
    india
    Posts
    54
    First thing u can try is
    command prompt use this set oracle_sid=<ur sid name>
    then >svrmgrl30 then startup.

    About internal password default will be 'oracle'

  3. #3
    Join Date
    Oct 2000
    Posts
    21
    also check in the control panel -> services, whether oracle has started or not.
    if not, then start it manually. check the same for listener process also.
    Pao de dabba
    B'ham

  4. #4
    Join Date
    Sep 2000
    Posts
    4
    Hi,
    thanks for the quick response. I had already tried setting the ORACLE_SID and then running svrmgr30. Svrmgr starts, but gives a message as 'unable to connect to destination'. Then i tried connect internal with password 'oracle' in the 'svrmgr>' prompt. Here also I got the same error message. Could anythiing be wrong with listener protocols? I use only TCP, and not IPC or pipes.

    sriram

  5. #5
    Join Date
    Oct 2000
    Posts
    33
    Try manager as password for internal.

    If not, you can set the ORACLE_SID parameter in the system/environmenmt tabl in the control panel.

    Otherwise, I am not sure if you can connect internal if your os account (WINNT LOGIN NAME FOR YOU) is not part of the oracle group. Try the same with the administrator account if u know the password.

    Richard

  6. #6
    Join Date
    Sep 2000
    Posts
    4

    Question

    hi all,
    thanks for your suggestions. I could make it work, though it looks weird. Initially I was setting the environment variables by right clicking 'My Computer' and selecting the tab environment variables, and adding them in the user variables. Then log off and log in as that user. But it was not taking effect as i opened the command prompt and try 'set' to see if the variables are there. So i did 'set Var=value' in command prompt specifically and then tried svrmgr30 and there you go.. it works.. I had to connect as 'system/passwd@service as sysdba' though, as internal/oracle did not work.
    another interesting thing was, I had to add the protocol IPC to the listener. just the TCP did not work. As the system is a staging machine i could not have it for a long time to fiddle around. now everything is working fine..
    Thanks again,

    Sriram

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width