Why has this Q been moved to the certification forum
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 4 of 4

Thread: Why has this Q been moved to the certification forum

  1. #1
    Join Date
    Aug 2002
    Location
    Brighton, England
    Posts
    93

    Why has this Q been moved to the certification forum

    Shutdown problems & LRM-00109 could not open parameter file
    Have a single standalone DB running under Win2k, I connect using the bequeath protocol. I get the above problem when trying to connect to my database.

    My Initialisation parameter file (G:\ORACLE\ORA81\DATABASE\INITmydb.ORA) contains the following...
    db_name = mydb
    service_names = myse
    instance_name = myin

    My registry settings are
    ORACLE_SID = myin
    ORA_myin_PFILE = G:\ORACLE\ORA81\DATABASE\INITmydb.ORA
    ORACLE_HOME = G:\ORACLE\ORA81
    ORA_myin_AUTOSTART = TRUE

    The only way I can get the database to open is to explicitly issue ....
    STARTUP PFILE=G:\ORACLE\ORA81\DATABASE\INITmydb.ORA

    Additionally I have recreated the service using ORADIM
    ORADIM -new -sid myin -intpwd oracle -startmode a -pfile G:\ORACLE\ORA81\DATABASE\INITmydb.ORA

    ....but I still get ...
    LRM-00109 could not open parameter file 'G:\ORACLE\ORA81\DATABASE\INITmyin.ORA'

    Where on earth is it getting this parameter file spec "INITmyin.ORA" when having speced "INITmydb.ORA", I have run out of ideas. Would apprectiate some guidance.

    Am also having shutdown problems whereby a shutdown immediate even fails, so have remedied this with a checkpoint followed by an abort, not sure if this could be related. For either problem the Bdump trace file does not help.

    Gus

  2. #2
    Join Date
    Oct 2002
    Location
    Breda, The Netherlands
    Posts
    317

    Re: Why has this Q been moved to the certification forum

    Originally posted by Gus

    My Initialisation parameter file (G:\ORACLE\ORA81\DATABASE\INITmydb.ORA) contains the following...
    db_name = mydb
    service_names = myse
    instance_name = myin
    Is this the entire init.ora? Are you following OFA? Otherwise you have to specify some more parameters.

    The only way I can get the database to open is to explicitly issue ....
    STARTUP PFILE=G:\ORACLE\ORA81\DATABASE\INITmydb.ORA
    This is normal behaviour. I do this all the time.

    Additionally I have recreated the service using ORADIM
    ORADIM -new -sid myin -intpwd oracle -startmode a -pfile G:\ORACLE\ORA81\DATABASE\INITmydb.ORA

    ....but I still get ...
    LRM-00109 could not open parameter file 'G:\ORACLE\ORA81\DATABASE\INITmyin.ORA'
    Why are you re-installing the service, while you can open the database via "STARTUP PFILE=G:\ORACLE\ORA81\DATABASE\INITmydb.ORA"?

    Are you sure that Oracle can find the init.ora on that path? Is the ASCII-file in use maybe? Or corrupt? If Oracle says it can't open the file, it really can't open it. So check the path and check to see if the file is still plain ASCII (don't open it in some editor and save it as MS Word or something like that).

    HTH,
    Erik
    An expert is one who knows more and more about less and less until he knows absolutely everything about nothing.

  3. #3
    Join Date
    Jun 2003
    Location
    India
    Posts
    118
    Try with same service name & Same database Name.
    vishal sood
    OCP 8

  4. #4
    Join Date
    Aug 2002
    Location
    Brighton, England
    Posts
    93

    :o My mistake!!!

    I pretty sure that if i use the same name for the instance, database and service names that it will work. I have had it working using different names for each before and there is no reason why this should not be working now as is so am determined to get to the bottom of this problem.


    Is this the entire init.ora? Are you following OFA? Otherwise you have to specify some more parameters.
    It was only an extract of the parameter file i presented, why? what other info do you need to see? Am OFA compliant.


    "The only way I can get the database to open is to explicitly issue ....
    STARTUP PFILE=G:\ORACLE\ORA81\DATABASE\INITmydb.ORA"

    Are you not aware that setting the pfile parameter in the registry in WinMS is also an alternative?


    "Are you sure that Oracle can find the init.ora on that path? Is the ASCII-file in use maybe? Or corrupt? If Oracle says it can't open the file, it really can't open it. So check the path and check to see if the file is still plain ASCII (don't open it in some editor and save it as MS Word or something like that)."

    Oracle can find the correct directory path my problem is that it is looking for the wrong file OOOOHHHH **** just realised I've cocked up big time and have overlooked something very simple AArrrghhh! Init param files having a naming format INITsid.ora and I've not followed this, can't believe I've gone and done this.

    SORRY for wasteing everyones time
    Gus

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width