ORA-12547: TNS:lost contact
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 8 of 8

Thread: ORA-12547: TNS:lost contact

  1. #1
    Join Date
    Aug 2000
    Posts
    30

    Thumbs up ORA-12547: TNS:lost contact

    Hi All,

    After installing oracle 8.1.6 on redhat linux 9.0 and subsequent glibc patches, I am getting the following error....

    Any of you have a solution for this problem?

    Advance thanks
    Regards,
    Nehruji
    [oracle@localhost oracle]$ sqlplus

    SQL*Plus: Release 8.1.6.0.0 - Production on Thu Mar 13 09:09:59 2003

    (c) Copyright 1999 Oracle Corporation. All rights reserved.

    Enter user-name: scott
    Enter password:
    oracleoralin: relocation error: /usr/oracle/lib/libjox8.so: undefined symbol: __fixunssfdi
    ERROR:
    ORA-12547: TNS:lost contact

    Posted

  2. #2
    Join Date
    Sep 2002
    Location
    England
    Posts
    7,333
    is your oracle sid set

  3. #3
    Join Date
    Aug 2000
    Posts
    30
    yes..

  4. #4
    Join Date
    Oct 2002
    Posts
    391
    below is my error. i did this as a sidadm user. i am on sap. however, with orasid, i am totally fine. advises?

    SQL> connect / as sysdba;
    exec(): 0509-036 Cannot load program oracleSid because of the following errors:
    0509-150 Dependent module libjox9.a(shr.o) could not be loaded.
    0509-022 Cannot load module libjox9.a(shr.o).
    0509-026 System error: A file or directory in the path name does not exist.
    ERROR:
    ORA-12547: TNS:lost contact

  5. #5
    Join Date
    May 2001
    Location
    San Francisco, California
    Posts
    510
    Cause:
    The LIBPATH environment variable is not set properly.
    Fix:
    Add the following: $ORACLE_HOME/lib to the LIBPATH environment variable.
    For eg: LIBPATH=$ORACLE_HOME/lib32:$JAVA_HOME/lib:$ORACLE_HOME/lib
    Remember the Golden Rule - He who has the gold makes the rules!
    ===================
    Kris109
    Ph.D., OCP 8i, 9i, 10g, 11g DBA

  6. #6
    Join Date
    Oct 2002
    Posts
    391
    my libpath are the same for 2 systems. and also, my original system can do sapdba. the problem is with this system which i copied from my original one.

    thanks

  7. #7
    Join Date
    Aug 2001
    Location
    chennai,bangalore
    Posts
    840
    Try to relink all the oracle libraries.

    from the command prompt execute

    relink all
    anandkl

  8. #8
    Join Date
    Oct 2002
    Posts
    391
    will this command " relink all" be dangerous?

    i am running sap on my oracle.

    thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width