Hi all,

I had a serious crash on my aix 4.2.1 server running oracle 7.3.3, where I lost a hard drive.. Unfortunately, backups were relying on the tar rmt0.1 feature, which caused the tape to rewind and write over existing backup files.. To make a long story short, we do not have a good backup.. We restored the database back to where it was in 2001 using the testbed. Now I am trying to pick up the pieces and trying to recover data.. I have brought up the database on a separate server using what database files I had left, and using the command alter database offline delete datafile...
I now have the database up with a partial list of database files..
My problem now is from the fact that eg: purge tablespace, I have purge1, purge2, and purge3 missing, and have files for purge4 thru 8.
I cannot get Oracle to display data from purge4 through 8, because it complains about purge 1 through 3 missing..
exp-00008: oracle error 376 encountered
ora-00376 file 6 cannot be read at this time
ora-0110: data file 6: '/log/Tpurge/Tpurge1.dbf'

I tried going into sql and using:
alter session set events '10231 trace name context forever, level 10';
Then I tried create table tpurge as select * from tpurge_history;
But I still get the above ora-00376 errors, complaining about the tpurge1.dbf..
Is there a way, perhaps using sql, asking it to list the latest transactions in that table, and going back one day at a time perhaps, till it comes to where it realizes it is missing that tpurge3 database file? Or is there a reader that can read oracle database files and make sense of them?

Any help/suggestion is appreciated. I can pretty much try any command, since it is set up on its own, and can be copied/tried again.. So send me your destructive sql statements. I will post the one that worked for me.. and I am sure it will help anyone in the future who comes into this situation..