sys user not connecting
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 8 of 8

Thread: sys user not connecting

  1. #1
    Join Date
    Jun 2003
    Posts
    108

    sys user not connecting

    Hi Everyone,

    My sys user is not connecting.The following error msg i got.

    ORA-01925: maximum of 20 enabled roles exceeded
    Warning: You are no longer connected to ORACLE.

    My parameter shows [ max_enabled_roles = 20] in my sql.

    But i am unable to find the same in my init.ora file.
    How can i change the max_enabled_roles value into init.ora file.

    Pls help.Thanx in advance.

  2. #2
    Join Date
    Dec 2001
    Location
    UK
    Posts
    1,684
    Hi.

    If it's not in your init.ora then add it:

    max_enabled_roles=100

    Then restart your instance.

    Cheers
    Tim...
    OCP DBA 7.3, 8, 8i, 9i, 10g, 11g
    OCA PL/SQL Developer
    Oracle ACE Director
    My website: www.oracle-base.com
    My blog: www.oracle-base.com/blog

  3. #3
    Join Date
    Aug 2000
    Location
    Singapore
    Posts
    323

    Re: sys user not connecting

    Originally posted by sri_dba
    Hi Everyone,

    My sys user is not connecting.The following error msg i got.

    ORA-01925: maximum of 20 enabled roles exceeded
    Warning: You are no longer connected to ORACLE.

    My parameter shows [ max_enabled_roles = 20] in my sql.

    But i am unable to find the same in my init.ora file.
    How can i change the max_enabled_roles value into init.ora file.

    Pls help.Thanx in advance.
    Try this.

    shutdown the database and increase the value of the
    init.ora file parameter max_enabled_roles to a value greater than the default will resolve this problem.

    Alternatively try INTERNAL to connect.


    Hope this helps.
    Nagesh

  4. #4
    Join Date
    Jun 2003
    Posts
    108
    Thanx for ur answer.

    I have one more doubt, my init.ora is not showing the max_enbled_roles.
    But my show parameter command shows max_enabled_roles = 20.

    is it possible, it would be great if u clear this doubt.

  5. #5
    Join Date
    Nov 2002
    Location
    New Delhi, INDIA
    Posts
    1,796
    Add the line
    max_enabled_roles = 100
    to ur init parameter file.
    Amar
    "There is a difference between knowing the path and walking the path."

    Amar's Blog  Get Firefox!

  6. #6
    Join Date
    Jun 2003
    Posts
    108
    Thanx a lot .It works fine.

  7. #7
    Join Date
    Oct 2002
    Location
    Breda, The Netherlands
    Posts
    317
    Originally posted by sri_dba

    I have one more doubt, my init.ora is not showing the max_enbled_roles.
    But my show parameter command shows max_enabled_roles = 20.

    is it possible, it would be great if u clear this doubt.
    MAX_ENABLED_ROLES has a default value of 20 and because of that the parameter doesn't have to be in the init.ora. If you want to overrule the default value, then you must specify it in the init.ora.

    I hope this takes the doubt away.

    Erik
    An expert is one who knows more and more about less and less until he knows absolutely everything about nothing.

  8. #8
    Join Date
    Jun 2003
    Posts
    108
    Now I am so clear.Thanx a lot and it works fine now.

    Srini

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width