Vni-4044,urgent
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 10 of 10

Thread: Vni-4044,urgent

  1. #1
    Join Date
    Aug 2003
    Location
    china
    Posts
    26

    Vni-4044,urgent

    When searching the remote node in OEM for ORACLE9i, i got the error VNI-4044, node may be down , network may be down or slow.

    But I checked that the agent service is started normal in the remote node, and the network is normal too. However, I found the node name is change automatically from 's2000d'( i typed in) to 'is-s2000d' as shown in the error message.

    What's the problem? pls advise.

    Thanks in advance

  2. #2
    Join Date
    Feb 2001
    Location
    Adelaide, Australia
    Posts
    159
    Sorry, what action are you performing when you get the error?

    Are you trying to 'discover' the node?


    Please also post the exact error message displayed.

  3. #3
    Join Date
    Aug 2003
    Location
    china
    Posts
    26
    yes, when discovering the node.
    The error is VNI-4044, message is about the same i described in the first post.

  4. #4
    Join Date
    Jul 2002
    Posts
    335
    Try typing in the ip address as opposed to the host name when discovering the node.

    Make sure your network setup is ok, do a nslookup from both the oms and the target node. If you use DNS get your network administrator to check the setup.

    Make sure the agent is functioning correctly on the target node, check its status, and make sure it and nothing else are using ports 1748 and 1754 (use tnsping).

    Bazza

  5. #5
    Join Date
    Aug 2003
    Location
    china
    Posts
    26
    bazza,

    I tried with IP, and got the same error message;

    Try 'TNSPING s2000d', it's OK.

    The problem happened just these days, it was normal before.

    I can connect to the remote node oracle with SQL_PLUS. and could you pls give a more detailed procedure on the solution you suggested.

    Thanks

  6. #6
    Join Date
    Jul 2001
    Location
    Slovenia
    Posts
    422

    Re: Vni-4044,urgent

    Originally posted by yanliu73
    However, I found the node name is change automatically from 's2000d'( i typed in) to 'is-s2000d' as shown in the error message.
    What about tnsping is-s2000d? Define this alias.
    Toma
    "A common mistake that people make when trying to design something completely
    foolproof is to underestimate the ingenuity of complete fools" - Douglas Adams

  7. #7
    Join Date
    Aug 2003
    Location
    china
    Posts
    26
    Tomaz
    It's the same.

    Any hints from anybody?? it's frustrating.

  8. #8
    Join Date
    Jul 2002
    Posts
    335
    -----------------
    The problem happened just these days, it was normal before.
    -------------------

    Something has changed. If you are happy the agent set up has not changed, then the network set up has.

    This is from metalink:

    Here is what happens during the discovery process.
    1. A hostname or ip address is entered from the EM Console.
    2. This request is forwarded to the OMS.
    3. The OMS takes that information and resolves it to an ip address (if needed).
    4. Then in order to get the fully qualified hostname (which is needed
    if dealing with multiple DNS domains), the OMS does a reverse NS
    lookup and converts the ip address to the canonical hostname.

    To simulate OMS discovery process, issue the following at a command prompt:

    nslookup

    The following information should be returned:
    Server:
    Address:

    Name:
    Address:
    Aliases:

    Next, take the ip address that was returned for the server and enter:

    nslookup

    The following information should be returned:
    Server:
    Address:

    Name:
    Address:

    If the fully qualified name of the server is not returned, DNS needs to be
    corrected so the reverse NS lookup name is correct or manually edit the
    HOSTS files on each of OMS / Agent systems.
    If the HOSTS file option is used, the entry should follow this format:



    ie. 111.111.111.111 myhost myhost.us.oracle.com

    This is with the fully qualified hostname, on port 1748, that the
    Agent Gateway of the OMS contacts the Intelligent Agent to get
    services information.

  9. #9
    Join Date
    Aug 2003
    Location
    china
    Posts
    26
    Hi bazza,
    I tried as you told, below is the result, any further advice?
    and how can I know If the HOSTS file option is used or not.


    Z:\>nslookup s2000d
    *** Can't find server name for address 192.168.0.1: Non-existent domain
    *** Default servers are not available
    Server: UnKnown
    Address: 192.168.0.1

    Name: s2000d.Software.Arches.com
    Address: 192.168.0.24


    Z:\>nslookup 192.168.0.24
    *** Can't find server name for address 192.168.0.1: Non-existent domain
    *** Default servers are not available
    Server: UnKnown
    Address: 192.168.0.1

    *** UnKnown can't find 192.168.0.24: Non-existent domain

    Z:\>netstat

    Active Connections

    Proto Local Address Foreign Address State
    .
    .
    .

    TCP w2000z1:3814 IS~S2000D:1748 ESTABLISHED --note the name changed
    TCP w2000z1:3815 S2000B:1748 ESTABLISHED
    TCP w2000z1:3816 w2000z1.Software.Arches.com:1748 ESTABLISHED
    TCP w2000z1:4600 w2000z1.Software.Arches.com:4601 ESTABLISHED
    TCP w2000z1:4708 S2000B:microsoft-ds ESTABLISHED
    TCP w2000z1:7772 w2000z1.Software.Arches.com:1711 ESTABLISHED
    .
    .
    .

    Z:\>tnsping s2000d

    TNS Ping Utility for 32-bit Windows: Version 9.2.0.1.0 - Production on 16-8 -2
    003 15:13:08

    Copyright (c) 1997 Oracle Corporation. All rights reserved.

    ʹõIJļ:
    C:\oracle\ora92\network\admin\sqlnet.ora


    ʹ TNSNAMES
    Attempting to contact (DESCRIPTION = (ADDRESS_LIST = (ADDRESS = (PROTOCOL = TCP)
    (HOST = S2000d)(PORT = 1521))) (CONNECT_DATA = (SID = testERP) (SERVER = DEDICAT
    ED)))
    OK50룩 --tnsping OK

  10. #10
    Join Date
    Oct 2000
    Location
    Saskatoon, SK, Canada
    Posts
    3,925
    Check with your network administrator to see the IP alias mapping had been set properly. If you have had any firewall, open to accept requests to appropriate ports. Looks like a local domain issue.

    Sam
    Thanx
    Sam



    Life is a journey, not a destination!


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width