tnsping takes long time on 9i instance
DBAsupport.com Forums - Powered by vBulletin
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: tnsping takes long time on 9i instance

Hybrid View

  1. #1
    Join Date
    Dec 2002
    Location
    Chennai, India
    Posts
    104

    tnsping takes long time on 9i instance

    Hello Gurus,

    I found tnsping takes aroung 360ms on W2K,9i
    where as the same db instance shows 60ms on NT,Oracle7.x
    Because of this sqlplus is very slow on my Win2k box
    Any pointers?

  2. #2
    Join Date
    Oct 2000
    Location
    Saskatoon, SK, Canada
    Posts
    3,925
    Do a normal ping and if it also takes that long then its an issue with your network. Make sure its running on FULL and not HALF-DUPLEX

    -Sam
    Thanx
    Sam



    Life is a journey, not a destination!


  3. #3
    Join Date
    Dec 2002
    Location
    Chennai, India
    Posts
    104
    using ping i will get the response with in 10ms

  4. #4
    Join Date
    Oct 2000
    Location
    Saskatoon, SK, Canada
    Posts
    3,925
    Can you please give us the following informations:

    Code:
         1. What is the Oracle Server Version & OS version
      
         2. What is the client version and the OS
    
         3. Your tnsnames.ora file after masking your host name/ip address information
    
         4. Your listener.ora file with the same condition as above
    
         5. Your sqlnet.ora file
    
         6. Also please list the Protocols used on your client & the server
    Sam
    Last edited by sambavan; 07-23-2003 at 12:40 PM.
    Thanx
    Sam



    Life is a journey, not a destination!


  5. #5
    Join Date
    Dec 2002
    Location
    Chennai, India
    Posts
    104
    Hi,

    I am using Oracle 9.2 database. I have created three instances manually using scripts.
    Here is my configs.(mentioning only for one instance)

    1. Listener.ora
    LISTENER =
    (DESCRIPTION_LIST =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = TCP)(HOST = XX)(PORT = 1521))
    )
    )
    )

    2. tnsnames.ora
    ACC=
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = TCP)(HOST = XX)(PORT = 1521))
    )
    (CONNECT_DATA =
    (SERVICE_NAME = ACC)
    )
    )
    3. sqlnet.ora
    SQLNET.AUTHENTICATION_SERVICES= (NTS)
    NAMES.DIRECTORY_PATH= (TNSNAMES)

  6. #6
    Join Date
    Dec 2002
    Location
    Chennai, India
    Posts
    104
    Firt time tnsping takes >800ms
    second time onwards this takes 80-100ms, why??

  7. #7
    Join Date
    Aug 2002
    Location
    Colorado Springs
    Posts
    5,253
    Are you identifying the host by ip address or by name? If the latter, then it's possible that the delay is caused by the DNS being slow to resolve the name.
    David Aldridge,
    "The Oracle Sponge"

    Senior Manager, Business Intelligence Development
    XM Satellite Radio
    Washington, DC

    Oracle ACE

  8. #8
    Join Date
    Dec 2002
    Location
    Chennai, India
    Posts
    104
    Am using IP address not the name

  9. #9
    Join Date
    Jul 2001
    Location
    Slovenia
    Posts
    422
    Do you have more NICs on this box? Or any virtual ones, like vmware?
    Tomaž
    "A common mistake that people make when trying to design something completely
    foolproof is to underestimate the ingenuity of complete fools" - Douglas Adams

  10. #10
    Join Date
    Dec 2002
    Location
    Chennai, India
    Posts
    104
    Ya, I have 4 NIC's in my box. But this same configuration is available in my NT,Oracle 7.x box but here connections are very fast?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width