Unable to initiallize ORACLE
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 3 of 3

Thread: Unable to initiallize ORACLE

  1. #1
    Join Date
    Jul 2003
    Posts
    3

    Unable to initiallize ORACLE

    Hi,
    I have deleted a Datafile physically.
    Now I am unable to initiate the Database.
    My Oracle version is 8.1.7.
    I have tried the following.

    1. Connected to server manager and startup and used
    alter database open.

    It is giving and error could not open the database and
    showing the path of the datafile which I have deleted.

    2. I have created the datafile which i have created. But still
    it is giving the same error



    Please give me steps to initiate

  2. #2
    Join Date
    Nov 2002
    Location
    New Delhi, INDIA
    Posts
    1,796
    1. Restore datafile from backup, apply archived redolog if in archive log mode.
    2. If not in archive log mode, restore whole database from cold backup.
    3. If cold backup not present, then drop the datafile (as suggested above) or tablespace.
    4. After opening take a backup.
    5. Read the following

    Oracle9i Database Concepts

    Oracle9i Backup and Recovery Concepts
    Amar
    "There is a difference between knowing the path and walking the path."

    Amar's Blog  Get Firefox!

  3. #3
    Join Date
    Dec 2000
    Location
    Mumbai
    Posts
    38
    1. Which is the datafile ? whether it is index data file or temporary datafile.
    2. If it is any of the above datafiles dont worry the database can be opened.
    3.Login in as internal
    svrmgr> startup mount
    svrmgr> alter database datafile 'path of file' offline drop;
    svrmgr> alter database open.
    Then recreate the datafile of the tablespace and rebuild the index or recreate the temporary tablespace.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width