two pmon running for same db(No parallel)
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 5 of 5

Thread: two pmon running for same db(No parallel)

  1. #1
    Join Date
    May 2003
    Posts
    46

    two pmon running for same db(No parallel)

    In one Production Box many(7) Databases running....and when I run ps -ef|grep pmon, 2 pmon entries found for the same database.....

    oracle 12656 1 0 May 25 ? 12:26 ora_pmon_usarpt
    oracle 8481 1 0 Jul 2 ? 0:30 ora_pmon_usarpt

    checked alert log and found someone(I am new to this envirnment) tried to open already running database by mentioning different pfile option...so I guess 2nd instance is running too.....

    Can anyone tell me what is the best/safest method to shut down the second instance without affecting the production DB....my fear is I should not shut down the production thing....

    Not much found in metalink/google etc on this.....

  2. #2
    Join Date
    May 2003
    Posts
    46
    Surprised......I have seen in this forum so many difficult questions were answered by big guns easily.....why not for this one?

    Common friends!(adewri, jovery, marist89, padmam, pando, sambavan, SANJAY_G,slimdave, DaPi,Abhaysk ...sorry if I missed out any senior guys here!) help me out this newbie.....

  3. #3
    Join Date
    Nov 2000
    Location
    greenwich.ct.us
    Posts
    9,095
    How about shutdown immediate? Shutdown the database that's supposed to be down and then kill -9 the rest. You waited 8 days for that?
    Jeff Hunter
    marist89@yahoo.com
    http://marist89.blogspot.com/
    Get Firefox!
    "I pledge to stop eating sharks fin soup and will not do so under any circumstances."

  4. #4
    Join Date
    Apr 2001
    Location
    Bangalore, India
    Posts
    727

    PMON

    First make sure you that your assumptions are correct.

    Look at the job started time. For an instance the time stamp will be same for all the background processes.

    Example

    ps -ef |grep TEST

    oracle 25978 1 0 05:29:45 - 0:00 ora_pmon_TEST
    oracle 47028 1 0 05:29:45 - 0:00 ora_ckpt_TEST
    oracle 54108 1 0 05:29:45 - 0:00 ora_arc0_TEST
    oracle 56868 1 0 05:29:45 - 0:00 ora_dbw0_TEST
    oracle 66650 1 0 05:29:45 - 0:00 ora_lgwr_TEST
    oracle 67222 1 0 05:29:45 - 0:00 ora_reco_TEST
    oracle 72320 1 0 05:29:45 - 0:00 ora_smon_TEST

    So check the PMON background process (take care of the server process ) and kill it which is having a different time stamp. And use ipcs command to release the semaphores and memory if allocated.

    Note: I never encountered this problem... So never tested....

    Best of luck!

    Regards,
    Thomas
    Thomas Saviour(royxavier@yahoo.com)
    Technical Lead (Databases)
    Thomson Reuters (Markets)

    http://ora600tom.wordpress.com/

  5. #5
    Join Date
    Feb 2003
    Location
    INDIA
    Posts
    96
    Dear Ramg

    Strange situation !!!!

    pl let me know the result after you shutdown immediate

    $ ps -ef | grep pmon

    I want to know your result eagerly.

    Thanks
    Dilip Patel
    OCP 8i

    Catch me online at Yahoo: ddpatel256

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width