error when upgrading with database upgrade assistant
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 5 of 5

Thread: error when upgrading with database upgrade assistant

  1. #1
    Join Date
    Apr 2001
    Posts
    257

    error when upgrading with database upgrade assistant

    I am trying to run Database Upgrade Assistant to upgrade from 8.1.7.3 to 9.2.0.3 on Windows 2000. It was ok until when it is trying to perform the backup. It gave "Could not generate backup of the database". I know I have enough space for the backup destination. This message is so generic, it's useless. Has anyone had similar problem before?

    Thanks,

  2. #2
    Join Date
    Sep 2000
    Location
    Chennai, India
    Posts
    865
    Is the database that you are trying to migrate running in archivelog mode or noarchivelog mode?

    Is your database service running when you run the upgrade utility?

    Is your database open when you run the upgrade utility?

    HTHU.

  3. #3
    Join Date
    Apr 2001
    Posts
    257
    To answer your question:

    - database was in noarchivelog mode
    - database service is running
    - database is in open mode

    Once I click on continue to do the upgrade after the backup failure message, it went ahead and did an upgrade. Looks like the upgrade was successful.

    I just don't understand why it was not able to back up for me.

  4. #4
    Join Date
    Nov 2002
    Location
    New Delhi, INDIA
    Posts
    1,796
    How are you trying to take backup ??

    As you database is in noarchive log mode, the only way u can take a backup is a cold backup. Shutdown and copy the files.

    What are you trying to do ??
    Amar
    "There is a difference between knowing the path and walking the path."

    Amar's Blog  Get Firefox!

  5. #5
    Join Date
    Apr 2001
    Posts
    257
    When running Database upgrade assistant, at the beginning it offers to back up the database to be upgraded. So I selected the backup option but it failed. I think as you said, since it's in noarchivelog mode, DBUA probably failed to back it up because cold backup is required.

    Thanks,

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width