SSO/9iAS Infrastructure
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 3 of 3

Thread: SSO/9iAS Infrastructure

  1. #1
    Join Date
    Feb 2001
    Posts
    295

    SSO/9iAS Infrastructure

    Guys,

    I'm installing OCS for demonstration purposes, but I faced some problems regarding Single Sign On. I installed 9iAS Infrastructure and OCS Information Storage and all was fine (when I say "fine" I mean "no errors pointed" and services up). However, when I try to install the midtier component, the following error is shown:

    "An error occurred while attempting to verify your host and port. Please verify your host and port values and that you can connect to this host, or enter new values. User Output Stringlist is: srv01.oralab.world*7777*

    Return value from SSORunning function is INVALID"

    I checked the host and port, it seems fine. I can open the OCS portal page using the browser pointing to the host above. The machine is a DC of a W2K domain (well, it is the ONLY machine in the domain).

    I searched Metalink, there were a few notes but no official solution. I tried some workarounds suggested there but none of them worked. Can you guys point me a possible reason for the error or some specific documentation regarding 9iAS and SSO?
    An ounce of action is worth a ton of theory.
    —Friedrich Engels

  2. #2
    Join Date
    Nov 2002
    Location
    New Delhi, INDIA
    Posts
    1,796
    For your SSO you need to start your OID.

    just do a ldapcheck from $ORACLE_HOME/ldap/bin and see if your ldap is running. if not then start them using the commands

    oidmon,oidctl. Look into OID administrators guide for more details and go through the 9IAS installation guide. Setting up 9iAS is one PITA, especially on linux.
    Amar
    "There is a difference between knowing the path and walking the path."

    Amar's Blog  Get Firefox!

  3. #3
    Join Date
    Feb 2001
    Posts
    295
    Well, I put OCS to work - at least it seems so, because several tests still need to be done. Installation and basic configuration are done.

    The problem wasn't in OID, but in the HTTP Server. I found out that Windows weren't starting the services in the proper order and that messed SSO ("Real Men use Unix"?). Pretty dumb issue, but at least I could learn better how 9iAS (doesn't) work.

    Another question, now regarding OID: when I try to login using "ias_admin" account, I get a LDAP bind error. Am I using the right account? Are there further configurations needed to operate OID? I tried using both Oracle Directory Manager (GUI) and web interface.
    Last edited by adrianomp; 07-07-2003 at 08:06 AM.
    An ounce of action is worth a ton of theory.
    —Friedrich Engels

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width