Automatic startup (9i) on Linux RH8 - problems
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 2 of 2

Thread: Automatic startup (9i) on Linux RH8 - problems

  1. #1
    Join Date
    Aug 2000
    Posts
    236

    Automatic startup (9i) on Linux RH8 - problems

    My dbstart and dbshut scripts work fine when run from the command prompt.

    Here is my dbora script.

    I have updated the oratab file.


    #!/bin/sh
    ORA_HOME=/u01/app/oracle/product/9.2.0.1.0
    ORA_OWNER=oracle
    if [! -f $ORA_HOME/bin/dbstart]
    Configuration Tasks to Perform as the root User
    then
    echo "Oracle startup: cannot start"
    exit
    fi
    case "$1" in
    ’start’)
    su - $ORA_OWNER -c $ORA_HOME/bin/dbstart &
    ;;
    ’stop’)
    su - $ORA_OWNER -c $ORA_HOME/bin/dbshut &
    ;;
    esac

    I created symbolic links to the dbora script in the appropriate run-level script directories, as follows:
    # ln -s /etc/init.d/dbora /etc/rc0.d/K10dbora
    # ln -s /etc/init.d/dbora /etc/rc3.d/S99dbora

    In spite of all this, my database does not start.

    Please help.

    Thanks,
    Nizar

  2. #2
    Join Date
    Jul 2001
    Location
    Slovenia
    Posts
    422
    unlink S99dbora, create it as script with line
    /etc/init.d/dbora > /etc/init.d/dbora.log
    read dbora.log
    Tomaž
    "A common mistake that people make when trying to design something completely
    foolproof is to underestimate the ingenuity of complete fools" - Douglas Adams

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width