error connecting to database from forms 6i
DBAsupport.com Forums - Powered by vBulletin
Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: error connecting to database from forms 6i

Hybrid View

  1. #1
    Join Date
    Mar 2001
    Posts
    78

    error connecting to database from forms 6i

    Hi friends,

    I keep getting a TNS packet writer failure error when trying to connect to the database with any Forms apps.

    I followed the supplied installation instructions exactly but cannot resolve this problem. Oracle 8.1.7 is the database used and it resides on another machine in the network. I created an entry in TNSNAMES.ORA with easy config. But I cannot get any of the builders, nor the SQL*Plus that came with the package, to connect to my database. I have no problem starting the SQL*Plus that was included in the 8.1.7 package, however.

    I read a few possible solutions on the newsgroups, and on here. Such as copying the TNSNAMES.ORA into both oracle home admin directories, renaming sqlnet.ora to .old. All with reboot, of course. Nothing is working. Listener is started, as well as other required services.

    I am running Windows 2000. All 8i components are v 8.1.7.

    Someone please help! Why do I keep getting this error?

    Thanks

  2. #2
    Join Date
    May 2002
    Posts
    2,645

    Re: error connecting to database from forms 6i

    Originally posted by star
    Such as copying the TNSNAMES.ORA into both oracle home admin directories, renaming sqlnet.ora to .old. All with reboot, of course.
    That would be OH\network\admin, yes? You meant that path, not OH\admin.

    Forms 6i on which platform?

    Nice dig against Windows.

  3. #3
    Join Date
    Mar 2001
    Posts
    78
    Hi,
    Thanks for the response.
    Forms 6i is also on windows 2000.
    I am stuck , please help me
    We are able to connect the same database from another machine thro an ODBC connection.

    regards

  4. #4
    Join Date
    May 2002
    Posts
    2,645
    Post your tnsnames.ora and sqlnet.ora files that forms is using.

  5. #5
    Join Date
    Mar 2001
    Posts
    78
    sqlnet.ora
    # SQLNET.ORA Network Configuration File: D:\oracle\ora81\network\admin\sqlnet.ora
    # Generated by Oracle configuration tools.

    #NAMES.DEFAULT_DOMAIN = db1.local

    #SQLNET.AUTHENTICATION_SERVICES= (NTS)

    NAMES.DIRECTORY_PATH= (TNSNAMES, ONAMES, HOSTNAME)

    sqlnet.expiretime=0

    tnsnames.ora

    # TNSNAMES.ORA Network Configuration File: D:\oracle\ora81\network\admin\tnsnames.ora
    # Generated by Oracle configuration tools.

    TEST.WORLD =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = TCP)(HOST = sori)(PORT = 1521))
    )
    (CONNECT_DATA =
    (SERVICE_NAME = db1.local)
    )
    )



    Please help.thanks

  6. #6
    Join Date
    May 2002
    Posts
    2,645
    sqlnet.ora
    # SQLNET.ORA Network Configuration File: D:\oracle\ora81\network\admin\sqlnet.ora
    # Generated by Oracle configuration tools.

    #NAMES.DEFAULT_DOMAIN = db1.local

    #SQLNET.AUTHENTICATION_SERVICES= (NTS)

    NAMES.DIRECTORY_PATH= (TNSNAMES, ONAMES, HOSTNAME)

    sqlnet.expire_time=0

    tnsnames.ora

    # TNSNAMES.ORA Network Configuration File: D:\oracle\ora81\network\admin\tnsnames.ora
    # Generated by Oracle configuration tools.

    TEST =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = TCP)(HOST = sori)(PORT = 1521))
    )
    (CONNECT_DATA =
    (SERVICE_NAME = test)
    )
    )


  7. #7
    Join Date
    Mar 2001
    Posts
    78
    oops.it didn't work.says service name could not be resolved

  8. #8
    Join Date
    May 2002
    Posts
    2,645
    What is the name of the database in the init.ora file?

  9. #9
    Join Date
    Oct 2001
    Location
    GA, USA
    Posts
    79
    Try to see that you donít have two tnsname.ora file in two different oracle home.
    Circumstances do not rise to meet our expectation. Embrace what you actually get. Open your eyes. See things for what they really are Thereby sparing yourself the pain of false attachements.

  10. #10
    Join Date
    Mar 2001
    Posts
    78
    db_name="db1"
    db_domain=local
    service_name=db1.local
    instancename=db1

    minesh, there are no duplicate ora homes.

    Please help me out.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width