Oracle Agent Installation Problem
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 8 of 8

Thread: Oracle Agent Installation Problem

  1. #1
    Join Date
    Feb 2003
    Location
    Peru
    Posts
    39

    Unhappy Oracle Agent Installation Problem

    i have installed Oracle 9.2.0.1.0 on RedHat 9.0, the agent installation phase didnt work, below is the error log, anybody has an idea on how to correct this?, i have reinstalled the agent but that no resolve the problem. (im attaching the complete log of the agent)

    thanks

    Gustavo

    -------- Tue May 27 15:56:29 PET 2003 ------------------------
    /home/oracle/product/9.2.0.1.0/bin/dbsnmp: error while loading shared libraries: libvppdc.so: cannot open shared object file: No such file or directory
    Agent exited at Tue May 27 15:56:29 PET 2003 with return value 127
    Restarting the agent at Tue May 27 15:56:29 PET 2003

    -------- Tue May 27 15:56:29 PET 2003 ------------------------
    /home/oracle/product/9.2.0.1.0/bin/dbsnmp: error while loading shared libraries: libvppdc.so: cannot open shared object file: No such file or directory
    Agent exited at Tue May 27 15:56:29 PET 2003 with return value 127
    Restarting the agent at Tue May 27 15:56:29 PET 2003

    -------- Tue May 27 15:56:29 PET 2003 ------------------------
    /home/oracle/product/9.2.0.1.0/bin/dbsnmp: error while loading shared libraries: libvppdc.so: cannot open shared object file: No such file or directory
    Agent exited at Tue May 27 15:56:29 PET 2003 with return value 127
    Restarting the agent at Tue May 27 15:56:29 PET 2003

    -------- Tue May 27 15:56:29 PET 2003 ------------------------
    /home/oracle/product/9.2.0.1.0/bin/dbsnmp: error while loading shared libraries: libvppdc.so: cannot open shared object file: No such file or directory
    Agent exited at Tue May 27 15:56:29 PET 2003 with return value 127
    Agent thrashing. Exiting dbsnmpwd at Tue May 27 15:56:30 PET 2003
    Attached Files Attached Files
    Gustavo Villaran

  2. #2
    Join Date
    Jan 2002
    Location
    Up s**t creek
    Posts
    1,525
    Check to see if you have LD_LIBRARY_PATH set and try relinking dbsnmp

    HTH
    Jim
    Oracle Certified Professional
    "Build your reputation by helping other people build theirs."

    "Sarcasm may be the lowest form of wit but its still funny"

    Click HERE to vist my website!

  3. #3
    Join Date
    Feb 2003
    Location
    Peru
    Posts
    39
    i have the environment variable set.

    this is my profile :

    # .bash_profile

    # Get the aliases and functions
    if [ -f ~/.bashrc ]; then
    . ~/.bashrc
    fi

    # User specific environment and startup programs

    PATH=$PATH:$HOME/bin
    unset USERNAME

    export LD_ASSUME_KERNEL=2.4.1
    export ORACLE_BASE=/home/oracle
    export ORACLE_HOME=/home/oracle/product/9.2.0.1.0
    export ORACLE_SID=ORCL
    export ORACLE_TERM=xterm
    export NLS_LANG=AMERICAN
    LD_LIBRARY_PATH=$ORACLE_HOME/lib:/lib:/usr/lib
    LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib
    export LD_LIBRARY_PATH
    export PATH=$PATH:$ORACLE_HOME/bin

    is this correct ?

    thanks
    Gustavo Villaran

  4. #4
    Join Date
    Nov 2002
    Location
    New Delhi, INDIA
    Posts
    1,796
    No just put this for you LD_LIBRARY PATH

    # .bash_profile

    # Get the aliases and functions
    if [ -f ~/.bashrc ]; then
    . ~/.bashrc
    fi

    # User specific environment and startup programs

    PATH=$PATH:$HOME/bin
    unset USERNAME

    export LD_ASSUME_KERNEL=2.4.1
    export ORACLE_BASE=/home/oracle
    export ORACLE_HOME=/home/oracle/product/9.2.0.1.0
    export ORACLE_SID=ORCL
    export ORACLE_TERM=xterm
    export NLS_LANG=AMERICAN
    export LD_LIBRARY_PATH=$ORACLE_HOME/lib:/lib:/usr/lib:/usr/local/lib
    export PATH=$PATH:$ORACLE_HOME/bin
    Amar
    "There is a difference between knowing the path and walking the path."

    Amar's Blog  Get Firefox!

  5. #5
    Join Date
    Feb 2003
    Location
    Peru
    Posts
    39
    ok i did it.

    now, how can i link again the agent? i have to reinstall de component?.

    sorry, its my first oracle installation under linux.

    thanks
    Gustavo Villaran

  6. #6
    Join Date
    Nov 2002
    Location
    New Delhi, INDIA
    Posts
    1,796
    as oracle user (the on u used for installation) give the comand relink all

    $ relink all

    HTH
    Amar
    "There is a difference between knowing the path and walking the path."

    Amar's Blog  Get Firefox!

  7. #7
    Join Date
    Feb 2003
    Location
    Peru
    Posts
    39
    ok, i did the "relink all".

    but give me some errors. maybe because it is RedHat9?

    i tried to startup the agent with agentctl start and didnt start.

    the "relink all" generate any log?

    thanks
    Gustavo Villaran

  8. #8
    Join Date
    Feb 2003
    Location
    Peru
    Posts
    39
    hi, i need some help of anyone....i have installed Oracle 9.2.0.1.0 on RedHat 9.0, and i cant make the oracle agent to work, anybody has installed Oracle on RH9?

    Thanks
    Gustavo Villaran

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width